Announcement

Collapse
No announcement yet.

Ask an ebike technical question get an answer within 30 minutes or so.

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Hi, my control pad of my DPC14 display is no longer working properly (the on/off button works fine but the plus and minus buttons don’t work)... so I am stuck on the password screen without being able to ride the bicycle. Any idea on how to fix it? This issue started when the battery drainaged. I have already unplugged and plugged all the cables. When I turn the Display pressing (on+ the plus buttons), a message “Voltage adjust Fail” appears.




    It doesn’t seem to be a pure bad function of the control pad: when I press plus and power together, I get the message “Voltage adjust failed”, when I press only power, it goes directly to the password screen without any message, so the plus button works although it is impossible to set the pin on the password screen

    Comment


    • paxtana
      paxtana commented
      Editing a comment
      If the screen is password protected and can you not enter that password then it sounds like you need a new display.

    Is there any way to bypass the display just to check if the problem is really the display? I can order a new display but it takes almost 3 months to arrive in my house due Customs. So I would like to be as much sure as possible about the source of the problem.

    Comment


    • paxtana
      paxtana commented
      Editing a comment
      Sure you can bypass display with a jumper or a program cable. Careful with the jumper, if you short the wrong wires with the jumper there is a good chance you will end up needing a new controller. See section 2 of this page https://electricbike.com/forum/forum...he-bbshd-bbs02

    Can someone help identify this folding Luna ebike model of this bike pictured with specs? Motor info, battery info, Mosso parts, etc.
    Thank you!

    Click image for larger version

Name:	a.jpg
Views:	504
Size:	139.8 KB
ID:	101194Click image for larger version

Name:	b.jpg
Views:	468
Size:	125.9 KB
ID:	101195
    Attached Files

    Comment


    • paxtana
      paxtana commented
      Editing a comment
      No idea. Maybe it is an unreleased product

    • johnnybravo
      johnnybravo commented
      Editing a comment
      Has Luna always used Bafang motors in their bikes since 2015?

    • paxtana
      paxtana commented
      Editing a comment
      Depends on the bike. We have used all sorts of motors over the years.

    Any specific way to jump the connector?

    Comment


    • paxtana
      paxtana commented
      Editing a comment
      Yes, the methods are described in the link I sent you three hours ago

    I have a brand new Cyclone 7.5KW motor that I am trying to get working with a brand new Nucular 24F controller. I am only able to get 2600RPM out of the motor at 72V 150A battery and 400A phase and if I turn up field weakening to 75A I am able to get it to 3300RPM. This is nowhere near the advertised 4000-4500RPM that Cyclone says or anyone elses posts about the motor. Why is my motor spinning so slowly? I had the same thing when I tried to use it with a Sabvaton SVMC72150 where it would only go to 2600RPM. Am I missing something? Will it only go to that RPM if I buy a Cyclone specific controller? My controller should be more than capable of powering this motor to high RPM

    Comment


    • paxtana
      paxtana commented
      Editing a comment
      That seems more something you would need to ask the seller about, but maybe someone here has suggestions

    • josephm15234
      josephm15234 commented
      Editing a comment
      I bought the motor directly from Cyclone in Taiwan and have emailed them a couple times and have not gotten any response. Was hoping someone who had experience with the 7.5KW motor might be able to shine some light on the issue

    Hoping to power a Surly Krampus (1st gen)... Have read older posts and they mention needing mods, plus chain line problems. Are there new parts available now that would make an e-Krampus more of an out-of-the-box upgrade?

    Comment


    buying a bbs02 for my wifes bike, If I get the luna mighty 30 tooth chainring how will the chainline be compared to the stock bfang? Am I better with the lekie blingring in 42 teeth?

    Comment


    • HIGHVOLTAGE
      HIGHVOLTAGE commented
      Editing a comment
      The Mighty Mini has practically no offset at all so it may offset your chainline compared to the default. Lekkie would be the way to go if you need offset that is similar to the default.

    • Cavi
      Cavi commented
      Editing a comment
      thanks, that is the way I will go then!!

    I have a fat bike conversion with the BBSHD motor, 52v 14ah battery, and 750c display. The bike worked flawlessly for about 70 miles and a couple of charges. Presently, it will hit about the 12 mile mark, and the motor becomes intermittent, and shuts off. No error codes are shown on the display, the speed sensor is working, and the battery voltage indication is still at 75%. The motor is cold to the touch. If I let it set for several hours or a day, it will become operational, but only for the same duration, and eventually stop again. It is not a loose or wet connection, as I have checked all of them. Could this be a faulty display unit? Please advise, thank you.
    Rich

    Comment


    • paxtana
      paxtana commented
      Editing a comment
      I would check for resistance on the connection with multimeter. Also if the battery/weather is freezing where you are keep in mind higher voltage sag and may want to insulate the pack

    • Ecwise
      Ecwise commented
      Editing a comment
      I am having a similar issue. I have random shutoffs when I first turn on my battery. I usually have to turn the battery on and off several times before the issue is resolved. Happening for about 6 months now and very annoying. I checked my voltage at the discharge port. I can see the voltage currently drop from 46v to 22v for a few seconds and then back to 46v. this happens several times before it finally stabilizes (if I leave the battery on for 10min before riding, I usually don't have any turning off issues). With the battery turned off it shows a voltage of 22V.

      I have a light hooked up to the battery and with the battery switch off, if I turn on the led light it briefly flashes on then goes off. if I wait a few tens of seconds I can get the light to turn on again...almost like it is constantly and slowly building a charge in the wires.

      if I repeat the analysis above and monitor the voltage at the charge port with the power switch off. the voltage initially reads 22V, then after switching on the light it drops to about 5v, then switching the power off on the battery, the voltage climbs back to 22V fairly quickly.

      I should mention this is a 17.5ah 48V jumbo shark that has about 3000miles on it. Panasonic GA cells.

      -David

      I am thinking the BMS is starting to fail?

    • paxtana
      paxtana commented
      Editing a comment
      That's pretty close to lvc on the controller if not the BMS, you should charge the battery more, or possibly replace the pack of it's that old. Especially in winter where sag is higher

    Question: I have a 48v luna 17.5ah jumbo shark and luna 2amp 80/90/100 charger. I bought it used and have charged it to 100% twice and rode until 49/50v. Now i switched the charger to 80% and wanted to top it off to "80%" before my next ride (instead of charging to 100%). when it was done charging, the battery read 54.8v on the bafang display. I read somewhere the battery is supposed to rest a couple hours before use, but i was surprised to see a 54'ish volt charge when the charger stopped (after a few hours of charging) with the 80% setting. I will test the battery in the morning using a multimeter. If its still at 54'ish, did i not drain the battery enough before trying to charge to 80%, so the charger decided to charge to 100%, or is the charger suspect and the 80/90/100 selector is no longer working so it will always charge to 100%, or are the cells in the battery out of balance and the charger thinks it charged to 80% but the battery itself is now confused... for lack of better technical understanding

    what are your thoughts/opinions?

    thanks!

    Comment


    • TaylorN
      TaylorN commented
      Editing a comment
      Have you ever seen/heard of that happening? Any thoughts if its possible to fix? If not, i imagine i should just periodically stop the charging process to test the volts and manually stop charging st 80%. Is it safe (longevity of the battery) to turn on/off the charging to take voltage measurements? Thanks!

    • paxtana
      paxtana commented
      Editing a comment
      Why would you need to turn off the charging to take voltage, it says voltage right on the readout?

      Yes I have heard of it happening, chargers can wear out and generally the more functions something has the more stuff there is to break. We have not made jumbo sharks for years so I assume this is quite old. If it is new you should hit us up.

    • TaylorN
      TaylorN commented
      Editing a comment
      Thanks for the reply. When you say it reads the volts right on the read out, do you mean i should turn the motor's display/controller on to check the volts on the screen? The charger does not have a volts display. Sorry for the stupid questions, i just dont have any instructions so i feared doing anything. I read your post about shark battery, but so far i have just been disconnecting the motor from the battery, turning the battery switch on, and then charging until the green light comes on. Is it safe to leave the motor/controller plugged into the battery while charging? And if so can i turn on the display/controller while charging to read the volts? Thanks!

    The Stubby Rear sur ron fender you sell... Does it come with fixing bolts?
    also, will the sur ron chain guard also fit a bike with the 58t sprocket?
    thanks

    Comment


    • paxtana
      paxtana commented
      Editing a comment
      I do not believe the fender comes with more than what is pictured.

      Far as I know nobody's tried that guard with 58t. Maybe it would work.

    Would like to know how to go about fixing error code 6 on my volimart 48v rear wheel drive???

    Comment


    • paxtana
      paxtana commented
      Editing a comment
      Ask the seller you bought it from?

    Hi,

    After 400 miles my fixie doesn't seem to want help me out pedaling anymore. The effort required to get it to assist once you have some speed means you cant get it to assist beyond a sprint which cant be sustained. Not sure what is wrong has the torque sensor failed any suggestions welcome.

    Adam

    Comment


    • paxtana
      paxtana commented
      Editing a comment
      I would email support, that's a new one to me. Heard of a very rare instance where sensor did not function at all but never only at a specific amount of pedaling. support@lunacycle.com

    I just saw a YouTube video of a few years ago a man had a luna cycle dashboard on his Sonders original fat tire bike and im looking to get one an x model, same bike with 500w and wondering if i can simply replace dashboard and be without speed limiting or atleast over 30 like he did. He also upgraded the motor and the controller. But the dashboard controls speed
    limits right?
    Last edited by James goes; 02-10-2020, 03:56 PM.

    Comment


    • paxtana
      paxtana commented
      Editing a comment
      Man we have not sold those kits for years..I think they can still be had elsewhere though. Try asking on sondorsforum

    My battery stop charging at 52.6v instead of 58.8v. the charger is set 100% at 1 amp. Could this be a BMS? I have Luna Wolf 52v Battery Pack 12ah. Luna Charger 52V Advanced 300W Ebike Charger

    Comment


    • paxtana
      paxtana commented
      Editing a comment
      Maybe, though I would check the charger first. Probably best to email support@lunacycle.com so we can work with you on getting it resolved

    Random question about the main reduction gear for the BBSHD. Have you guys at Luna ever considered producing a delrin version of the gear?
    It should be stronger than the nylon gear, quieter than the steel one. Would it be at risk of melting faster?

    Comment

    Working...
    X