Announcement

Collapse
No announcement yet.

If you have an X1 Enduro Luna bike, what's your opinion on it? How do you like it?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Originally posted by mw195 View Post
    Can someone explain to me how that cover would allow the crank arm to come off?
    I get that you want the cover bolt, but there should be pinch bolts on the crank arms, are there not? The outside bolt is there to pull the cranks on to the spindle, and the pinch bolts should serve the purpose of cinching the crank arm to the spindle.
    Is it possible that the pinch bolts were not checked?
    Again, not pointing fingers, just trying to understand what is going on as my bike is supposed to arrive in a few weeks.
    Thanks
    Pinch bolts were definitely checked! It fell off again (without the cover, pinch bolts tightened down). Now I just keep an eye on it..

    Good news: I just got word from Luna - they just shipped the replacement parts!

    Cheers

    Comment


      #32
      So, the pinch bolts are just coming loose from riding? Did you run blue loctite?

      Comment


        #33
        Originally posted by mw195 View Post
        So, the pinch bolts are just coming loose from riding? Did you run blue loctite?
        I would like to know this as well....are the pinch bolts coming loose as you ride or is the crank arm just slipping off the crank even with the bolts tight? This is a very strange issue and has me concerned with my bike coming in a few weeks......

        Comment


          #34
          I'm guessing the cover bolt came off much earlier in the ride than the crank arm did and the arm slowly moved outward while riding. When I tried to put the crank arm back on, the pinch bolts were still fairly tight and needed to be loosened before the arm would easily fit all the way back on. I think it's obvious that the bolt cover is far more problematic.

          I had tightened everything down just after my previous ride. At this point I'll be removing all and adding new loctite - while I wait to figure out how to get a new cover bolt.

          For the record: I love the bike.
          Last edited by dhartst; 1 week ago.

          Comment


            #35
            Originally posted by CRFan250 View Post

            I would like to know this as well....are the pinch bolts coming loose as you ride or is the crank arm just slipping off the crank even with the bolts tight? This is a very strange issue and has me concerned with my bike coming in a few weeks......
            I added loctite (admittedly hard to do because the bolt has to travel through a longer collar before reaching the thread) and it still fell off eventually (without the cap/cover).
            I then went apeshit, loctited the hell out of everything (including where the crank slides on), slightly over torqued everything and since then it has been rock solid. I might regret this later.

            Comment


              #36
              Originally posted by UltiCOW View Post

              I added loctite (admittedly hard to do because the bolt has to travel through a longer collar before reaching the thread) and it still fell off eventually (without the cap/cover).
              I then went apeshit, loctited the hell out of everything (including where the crank slides on), slightly over torqued everything and since then it has been rock solid. I might regret this later.
              Yeah...Think I will do the same when I get mine.....even loctite on the splines. Nothing a little heat won't remedy if you need to get it off. This seems like a serious problem for a bike in this price range. I think I will use Red loctite in this area as well......not good.

              Comment


                #37
                I've had my x1 for about two months/400 miles now and like other ive lost the crank bolts. I replaced the crank bolts with steel ones off Amazon. That fixed the problem for me. Other then that it's been a great bike.
                Last edited by Mattw; 1 week ago. Reason: Shit didnt make sense

                Comment


                  #38
                  Originally posted by Mattw View Post
                  I've had my x1 for about two months/400 miles now and like other ive lost the crank bolts. I replaced the crank bolts with steel ones off Amazon. That fixed the problem for me. Other then that it's been a great bike.
                  Wait...the crank bolts are aluminum? Hmmmm......it could be possible they are heating up and expanding.

                  Can you post a link to those bolts you bought?

                  Comment


                  #39
                  Thanks for the link! Ordered and I am going to change them first thing when I get my bike!
                  Last edited by CRFan250; 1 week ago.

                  Comment

                  Working...
                  X