Announcement

Collapse
No announcement yet.

rosenberger connection port terminals touched keys by accident caused a spark

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    rosenberger connection port terminals touched keys by accident caused a spark

    while lifting my bike my keys touched the exposed terminals and caused a spark on the connection port on my 52v fusion battery that came on my khs3000 that I bought new in may of 2019 , since the spark occurred the charger will not recognize the battery. the display is still working and reads 51v. Any suggestions on troubleshooting would be helpful. I have contacted lunacycle support . wondering if it fried the bms or if bms is replaceable or repairable or if maybe the Rosenberger plug needs replacement or any reccomendations on who can repair the battery. the battery has been working great and the cells are in good shape and have been well taken care of any suggestions or solutions thank you for your time

    #2
    Check the charge and discharge for voltage with a multimeter first, if you see voltage you might just have to clean off any carbon deposits with something nonconductive/nonflammable. CRC makes a cleaner like that

    Comment


      #3
      Thank you , there is no reading on the multimeter form the rosenberger terminals or the connection port from the battery. There is no spark if touched with metal like it originally sparked by accident. cleaning the charging port had no luck. I am waiting for a email response from the Luna support to determine if it’s repairable under warranty or if they can sell me a replacement . Joel the sales rep at lunacycle said the support department would have to determine if they could at least sell me a 52v dire wolf at a discounted rate or even a Black Friday sale whichever is cheaper but he could not sell it to me lunacycle support would have to make that decision Though I would prefer to keep this battery it fits nicely in the frame and has a really cool look, and I believe the cells are not damaged The bike still works and drives with the display reading correctly now at 49v. I have seen the thread about replacing the bms if that were to be the problem though I am not good at soldering . If there is a repair shop I can send it to that would be best even though I know it will be expensive. Or just as expensive or so to buy a new battery. All options are on the table at this point. do you know a easier way to get through to lunacycle support. I use the bike for a main source of commuting to work each day and would have no problem purchasing a new battery and trying to fix this one as well. another thought is that maybe the rosenberger connector is worn down by the spark and needs to be replaced. There it’s a company that sells the rosenberger parts if that were the case. again my soldering experience is not good and would still prefer sending it to a professional.

      Comment


        #4
        Well I don't see any email in our system that matches the email address you used when you signed up on the forum, and right now all inquiries are answered very quickly so it sounds like you may want to resend. If you used the trouble ticket system maybe the reply email address you entered had a typo or something who knows. You can email directly to the inbox via support@lunacycle.com or you can just let me know your order# and I will have an agent reach out to you via email

        Comment


          #5
          So other than that you can’t tell me if the battery is repairable or if anyone Luna or another company is willing to give a try at saving this battery. It doesn’t seem environmentally responsible to just discard without a honest effort if lunacycle built it you would think they would be interested in saving it for the customer and the sake of recycling being a planet earth friendly company if that is true. I have multiple emails to support@lunacycle using a different email address. The reason I had to use a different email for this forum is because I forgot my old forum password and got no response after multiple attempts.at trying the reset password link on the log in page . everything is typed correctly . I obviously don’t have a order# because I need support@lunacycle to contact me. It doesn’t matter to me which email you use I’m just looking for a complete reply about repair ability if so with option for repairs or recommended replacement with price and availability to purchase a similar replacement I apologize if I am coming across as frustrated I do appreciate the help. My email sent box would notify me if the mail did not go through successfully so I don’t know why I am not seeing a reply to dcashonly@hotmail.com which is the email I used to purchase the bike in 2019 and to recently contact support@lunacycle. and no there is no reply from Luna in the junk mail or spam box or any mailbox linked to my email. it’s a mystery to me too why I’m not able to see a reply.

          Comment


            #6
            Thank you for the info.

            I believe it is probably a little soon to jump the gun in saying that nobody is trying to help you, as when I looked up the email address you just provided me I do see an ongoing conversation you were having with support. Looks like you sent an email on the 19th, my agents sent you three email replies on the 19th, you replied on the 22nd and our lead support technician replied a few hours later on the 22nd. That was the last correspondence we see in our system on the main trouble ticket opened, though there is another ticket that agents also replied on. I would recommend replying to this email chain as I see four different email chains/support tickets opened by you on the issue, that makes it very difficult to address all of your concerns.

            If you are having trouble seeing these emails below is a copy of the last reply we sent two days ago

            Click image for larger version

Name:	2021-11-24 13_55_31.jpg
Views:	73
Size:	192.0 KB
ID:	144608

            So we need to know if you tried jumpstarting it. Also it would probably be worth mentioning in the reply to Seb that you are seeing zero volts on both, because that would typically indicate that your multimeter may be on the wrong setting, as it is not technically possible for there to be zero volts in the battery.

            Regarding buying another battery we can maybe figure something out sure, but direwolf may not fit as it appears your bike frame size is medium. Incidentally it appears your order# is 76972 if needed for reference.

            Comment


              #7
              Thanks weird how I’m still not getting the emails ,I thank you for the info. I am getting a reading of 45 from the voltmeter on the charge port and 50 from the discharge. I did the jumpstart for 25 seconds the charger came on I don’t think it reset the bms plugging back in normal still would not come on. And retesting the voltage after jumpstart came back with the same reading.
              waiting for the next step suggestions on new battery sounds likely let me know I’m ready to order one if that’s the solution thanks

              looks like Luna wolf 52v would be the best choice for my medium khs 3000 frame if the dire wolf won’t fit
              Last edited by Kangas; 1 week ago.

              Comment


                #8
                If you could have support @lunacycle email me back at kangas@ltcc.edu since my other email is not receiving the replies for some reason , so I can order a new battery

                Comment

                Working...
                X