No announcement yet.

Charging New Luna 52V shark pack, low amps

  • Filter
  • Time
  • Show
Clear All
new posts

    Charging New Luna 52V shark pack, low amps

    I just received my new Luna 52V 13.5AH Shark Pack (samsung cells) and 300W 52V advanced charger.

    1.) Set to 100% charge (per instructions) and 2 amps
    2.) Plug in charger, led is green, displayed voltage is 58.7
    3.) Plug in battery with power switch on, led goes to red, voltage goes to 51.3 and amps is 0.4.

    This happens no matter what %charge is used or for any of the amp settings (1-5A) or either of the battery switch positions.

    Also verified the amps with a wattmeter at 0.4A

    Shouldnt the amps be higher? Perhaps BMS is limiting it due to cell imbalances?

    I can push about 6A into my 52V 20Ah pack if at half charge, and you aren't much above half. I'm using a Satiator charger, but the voltage and current are what determines current input for a pack, so the charger brand shouldn't matter too much. But different chargers might tend to limit current sooner, or later, depending upon setup. My Luna Advanced charger can charge me up almost as fast as the Satiator from 50%, so I don't think this is a significantly limiting difference.

    So, yes, your currents are lower than I would expect, too. I would expect you to be able to push at least 2A, probably 3-4, at your apparent ~51.3V pack voltage. Try the charger's fastest charge rate and see if the current goes up. If so, it's probably just the charger set up, not the pack. But, if no change, I might suspect the pack or wiring is limiting it somehow. A poor electrical connection could cause this, too.
    Last edited by JPLabs; 12-20-2018, 09:18 AM.
    Fabrication is fun! Build something today. Show someone. Let them help. Inspire and share. Spread the desire.


      Thanks for the response

      I did try the charger at all the current settings and it makes no difference.

      I also tried connecting the charger to a power resistor and when I did that the charger outputted the correct amps for all settings (1-5)

      The battery has been on charger now for 24 hours and voltage is at 57.3 and same basic amps (~.4).

      Im guessing it will be charged in the next 4 hours.

      After its charged, Im going to let it sit for a day or two and then use it on the bike, if it still slow charges next time, Im going to contact Luna.


        Check out the Knowledge Base for the batteries, first. It is a forum section here. I vaguely recall that some batteries might need an adapter to fast charge with some chargers, or to work right. I have no idea if I'm right and if it would apply to you, but this is the Luna resource for such things.

        Also, here is the Luna documentation collection, including for batteries.
        Fabrication is fun! Build something today. Show someone. Let them help. Inspire and share. Spread the desire.


          Shows how chargers should work... Don't adjust till after talking with Luna support.

          See my completed Magic Pie V5 rear hub motor E-Bike build HERE.


            Thanks for the links, I have been thru all of those multiple times. I tried everything suggested that seemed to apply to my situation.

            I have load tested the charger and it appears to be working correctly (voltage and amps verified with a wattmeter).

            I think Im just experiencing 'break-in'. There is no mention of the amps being limited by the BMS during this period although it could be implied(Please prove me wrong). Not a big deal as many people probably dont have a way to monitor amps like on this charger.

            So after 28 hours, the charger finally cut-off. Luna recommends letting it sit for a day or two to balance after the initial charge. After 4 hours(being fully charged), I connected the charger for a brief period just to see what the amps where and they were finally larger than 0.4, I had the charger set to 1A and thats what I initially saw.

            I will let the battery sit for a day(no charger attached) and report back what I see.

            Im well versed in most of this battery stuff having been heavily into the RC hobby for 5 years and have probably used-up about 300 lipos.

            What Im new to is what the BMS does, I understand in theory and actually wrote software for one used in the aerospace industry, but many BMS can work differently in subtle ways and many times might get a new rev which works differently still(example:in one of the links provided it states to have the power button on the battery on before pluggin in charger with a statement that some BMS want the switch off first before plugging in charger followed by turning on the battery switch, and even another that states that the bms only works if the power switch is off....I have tried all these combinations including unplugging everything and waiting for the caps in the charger to discharge)

            Again, thanks for the responses!
            Last edited by linklemming; 12-20-2018, 10:38 PM.


              Good, that's a pretty reasonable assessment, I think.

              One more thought - it's not very cold, around freezing, when charging, is it? BMS or charger might limit rate @ cold.
              Fabrication is fun! Build something today. Show someone. Let them help. Inspire and share. Spread the desire.


                Well good appears to be the charger.

                While I did load test the charger (100ohm power resistor bank) and saw all the amp settings work as expected, I dont see the same behavior with the battery.

                I did a jumpstart procedure (charging thru the battery discharge connector) for a few seconds. Amp selection of 1-4 yielded 0.4amps and 5 yielded 5 amps....yeah.

                So its now charging thru the charging port just fine at 5 amps. I know I tried different amp settings, I guess I skipped the 5 amp setting. Next time I will take better notes.

                Probably just going to return the charger and get a cycle satiator
                Last edited by linklemming; 12-21-2018, 06:33 PM.


                  Sounds like the selector is defective. Email support and it will get replaced.


                    Just to follow up on this, Luna replaced the charger and all is fine now...Thanks