Announcement

Collapse
No announcement yet.

Programming a Bafang 750w Controller

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Programming a Bafang 750w Controller

    I need help with programming a Bafang 750 W 17v motor. I have made numerous attempts to activate the program with no success. I have downloaded the software from two separate sites. I purchased two cables, thinking that the first was defective. I have used two laptops running Windows 10 and one laptop running Windows 7. I’ve used no less than 7 different serial ports on the three laptops and confirmed the driver as, “USB-Serial CH 340. I followed the following procedures: 1) initially, the battery is not connected. With the battery not connected, I disconnected the lead from the controller to the display. 2) I connected the programming cable to the lead to the controller. 3) I connected the battery and turned it on. 4) I connected the programming cable to the laptop. 5) I checked the Device Manager to see which port the cable is connected and the driver name. 6) I started the software making sure the correct port was selected, and then clicked “Connect.” I sometimes get a screen with a disclaimer, sometime not, but in all cased the screen shows the bottom buttons grayed out, indicating no contact with the Controller. I’ve attempted these procedures on numerous days over the past two weeks. Help!!!

    #2
    It sounds like you've covered all the bases from your description. I'm linking this YT video just to give another checklist in case something was missed. It was helpful to me for my first hookup to do the programming. You probably have covered everything and may have even followed the guidelines in this particular vid already.

    Bafang BBS01, BBS02 and BBSHD Reprogramming - YouTube

    I will ask for clarification on your description of the Bafang motor. You say "750 W 17v motor". Is that a typo or a Bafang different from what I thought you were referring to? I didn't see mention of the specific Bafang like BBSHD, BBS02, etc.
    Last edited by TNC; 06-05-2021, 08:09 PM.

    Comment


    • Varius
      Varius commented
      Editing a comment
      I have exactly the same issue with my BBSHD. Even downloaded the Bafang programming software and it connect fine thru usb to serial, however none of the widgets are enabled after connect, except the disconnect. Cannot change anything. I suspect Lunacycle has a process you need to do on the controller before you can program it and it is so frustrating there are no instructions other than go to this PLC driver site and it should work. Can someone from Lunacycle please update connecting to your controller so the programming software will allow you to make changes, or give a pointer to a more current programming utility if any and all will work with your controller? Thanks
      Last edited by Varius; 06-05-2021, 03:50 PM.

    #3
    Varius, can you clarify the term "widgets" that weren't enabled? Are you getting to the screens with the tabs that have the elements that you want to tune? Have you exactly followed the directions of the guy in the video I linked above? His was one of the best, most thorough descriptions I've seen as he didn't seem to take anything for granted, down to even how to procure the programming cable.

    I am no guru on this programming whatsoever, but following the videos instructions very carefully got me going. My BBSHD came from Bafang USA the first of April. It has the factory ability to run the throttle at the same time as pedaling which some apparently don't. I tried to get my BBSHD from Luna, but they were out of 68-73mm sizes at the time. I got the program cable from Luna and used their program as the guy in the video suggested. I also used the source of the drivers as suggested by the video. I have home edition Windows 10.

    I'm thinking there is one small element being missed that might explain your problem. Does the video described everything you've tried step-by-step?

    Comment


      #4
      io avevo lo stesso problema però sullo stesso laptop che lo scorso anno funzionava! allora ho pensato che qualche aggiornamento del pc aveva modificato qualcosa impedendo l'avvio del programma Bafang...così ho preso il mio vecchio EEEEpc ho installato da zero ( format c ) win seven starter ( sul piccolino gira benissimo ) e ha funzionato subito...quindi ho bloccato gli aggiornamenti e me lo tengo così, solo per la programmazione del motore Bafang! quindi penso che chi ha dei problemi, essi siano a causa degli aggiornamenti dei S.O. che invalidano i parametri del software di programmazione Bafang....avevo provato di tutto, win 8.1, win 10, niente! porte virtuali bloccate! e alla fine il piccoletto con 7 starter NON AGGIORNATO e con Internet scollegato, ha funzionato e funziona alla grande!...

      Comment

      Working...
      X