Announcement

Collapse
No announcement yet.

Help! Error 30 due to programming attempt

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Help! Error 30 due to programming attempt

    Hi,
    I'm a new BBSHD/ 52V owner in the UK, hoping to use the bike mainly offroad. I've had the new motor kit on the bike for about an hour, and at first attempt at reprogramming I've got into trouble and am now sorely wishing I'd just left it stock.

    This all started when I bought a programming cable off eBay. It connected up fine, then when halfway through updating the second tab (pedal assist) it lost its connection with the controller. It cannot get connection now, and the bike is showing error 30 and going nowhere.

    So I cannot connect to the Bafang software or the reflash software supplied by Golden Motor https://www.youtube.com/watch?v=U4KdSIWpR48, which gets to the final stage (writing changes back to the controller) then says connection error, and I have the error code 30 which means the bike is dead.

    What are my options? Preferably not horrifically expensive ones. The bafang kit has done almost nothing on the bike- so everything is brand new. Could I just have a faulty programming cable that worked OK at the start? But has it created issues that a better cable now won't resolve?

    If I can sort the error code and get the bike running as standard, Despite the fact I'm now justifiably terrified of going anywhere near it with a programming cable, I'd still ideally like to be able to change the settings to make it more responsive for singletrack riding. (get throttle working on PAS0, reduce the number of signals to get PAS working again after I've actuated the brake sensors). Also, if possible get it working above its 28 amp limit- (I understand they used to go to 30 amps and are safe to do so) - and generally optimize it better where possible for my 52Volt battery.

    I've seen mention in various places of 'error 30 code due to attempting to reprogram controller', which is clearly what has happened to me, so I'm hoping people on here may have some answers. Is this a common thing? Are there any solutions? Have I fried my controller already?

    If I bought a new stock controller and left it alone would that be likely to fix the issue?

    I was so excited plugging in the cables yesterday and resetting all the values to my carefully researched levels. Was really looking forward to my next ride on a better setup bike. If I'd only known that 5 minutes later I'd have potentially murdered my brand new controller...

    #2
    You would not expect issues on a new unit but if you have a bad connection in the main harness connector that can cause the error 30 and since that is how the cable also connects could cause that to be flaky. Maybe look there for any signs of an issue like a broken pin maybe? If no signs of a problem there I would keep inspecting all the wires and connections I can find.

    Comment


      #3
      Had exactly same issue, had new 1000watt bbshd kit, attempted to Change some settings, can’t remember what i did, got the same error. Finally had to replace the controller, I could configure the settings on the new controller. I used the same cable on other bikes without problems. Not sure what I did, just thinking if I had attempted to change max amp setting,

      Comment


        #4
        I fixed it!
        Bafang Error 30 gone, hopefully never to be seen again!
        I used a different cable, the guy I bought the first one off kindly sent a replacement FOC. I also used a different USB port on my laptop. the other USB ports are wobbly (6 year old laptop), so it might not have been the cable after all...
        With the new cable I was able to reflash the controller first try- easy process described in the above youtube video.
        So pleased! Thought I was into a new controller.
        I'm now wondering if I dare change the settings on my reborn controller? I suppose I could reflash it again if I run into the same problems again. Part of me just wants to not risk it and learn to live with the default Bafang settings, at least for a while. It feels so nice and amply powerful anyway- as I'm still comparing it to analog pedalling. I only wanted to make minor changes anyway like get throttle working in PAS0 and get faster response on pedal assist after braking for singletrack speed.
        I see there's another guy on the youtube comments whos fixed his error 30 with this reflash process so it is working for people at least some of the time.

        Comment


          #5
          After getting rid of the error 30 with the reflash, I tried reprogramming the controller again. Another error 30 straight away. Reflashed again and got rid of the error- but don't fancy playing with this again.
          Because my unit is so new this leaves me with the suspicion that Bafang may now have it in the firmware to throw up an error 30 when anybody attempts to change (reprogram) the controller settings.
          I suspect this because of the unremoveable 28A limit that they have also introduced. It's common when companies get bigger for them to protect against warranty claims in this way- stop customers from customising their products in such a way that they can be set up to break themselves.

          it's a shame as part of the reason I went for this kit was to enjoy customising it.

          Comment


            #6
            How about if you change other settings? I would also question changing any settings from the defaults (especially raising the current limit) before you get some ride time in and start to understand what it all does and how you end up using it. The default settings do work well for a lot of people.

            Comment


              #7
              Hi,

              indeed, it seems we have a programming problems with new controllers.
              I did get this same situation but with Eggrider v2.
              My local Bafang dealer did know this issue and it is related to programming attempt, which locks the controller rightaway.
              My long story to try figure out my frustrating fault:
              https://electricbike.com/forum/forum...push-backwards

              Weird that there is not any topics about this new controller problems?
              I'm getting my new bbshd for my new build from em3ev (luna is very expensive to order to Finland..) soon, and it should be with 30A controller, dunno if it is old or new.
              Lets see how it reacts to Eggrider, hopefully I didn't buy Eggrider for nothing....

              Good to know that 30H can be re-flashed away, I have one brand new controller with this problem and error. Almost did throw it away but ill keep it as spare, thanks for info :)

              Comment


                #8
                What’s the reflash software, where can I get it? Bit confused with ‘reflash’ software and ‘programming’ software. I think I have the software which I used to change the settings, is the ‘reflash ‘ different to this ? Appreciate any help, thanks

                Comment


                  #9
                  When they are talking about the reflash they are speaking of the actual program running on the controller, not just the settings. Pretty sure its done with the programming cable. Not sue where you get it hopefully someone else will answer that.

                  Comment


                    #10
                    Reflashing is mentioned in first message.
                    You need a programming cable and software from Golden Motor website. I have not done this myself so i don't know more about it.
                    I will try in near future, wiser then.

                    Comment

                    Working...
                    X