No announcement yet.

Upgrading halfords ebike - help requested.

  • Filter
  • Time
  • Show
Clear All
new posts

    Upgrading halfords ebike - help requested.


    New member here and doing my first 'build', which is an upgrade of a halfords 'assist' bike.

    Here's the original bike on the halfords website

    So basically, I will be probably buying a 1500w beast in the future, but for now, I just wanted to see if I could add a throttle to this and maybe do better on the pedal assist etc. I'm using the standard 24v 7ah(I think, not sure on that) battery and the original 250w brushless motor. Also, I'm using the original cable that went from the old controller, to the motor. Other than that, my kit includes a new 24/36v, max 350w controller, new brakes, pedal assist, throttle and speed sensor.

    So far, I've hooked up the battery to the controller and that lights up and appears to work ok. However, no matter what I try, I can't get the motor to move. I've connected the phase wires through using the colour coding from the controller to the original cable, I got some molex/amp connectors and I made up my own hall sensor connection that fits the one on the controller. I fitted the PAS to the bike...finding out during that, I needed a 'crank puller' to get the bloody thing of the spindle lol (I am total noob), had to use gorilla super glue as there was no ring nut to hold the sensor ring on, used some plastic washers to space between that and the disc/magnet sensor. Anyway, thats fitted fine.

    So using a multi meter, I've tested from the positive of the battery, and found that I am getting voltage of approx 28v on my connections, right down the last connection a few centimeters before it goes into the motor. So I can only assume, without taking the motor apart which is a bit beyond me, that it is getting power.

    But I connect the throttle and movement, no twitching, no sounds. I connect the PAS and crank the pedals round and same thing. So, then I'm thinking that maybe I've done something wrong etc.

    However, I then connect the speed sensor, you know the one with the little flashing red LED and the magnet you fix to one of your spokes that corresponds to where the sensor is, so it passes the sensor as the wheel goes round.. I can see the LED flashing as I crank the wheel, but the LCD display shows no speed?

    Also, its my understanding, that the throttle voltage should be something between 1v and 4v, depending on how far back you have moved the throttle? well when I test the voltage from the positive connection of the battery, to the connections on the throttle, I'm getting the full 28v?

    Any help greatly appreciated, I know I must be doing something wrong here, the motor worked fine before I ripped open the old controller to take the cables off it and connect to the new one. The battery is fine, fully charged etc...the LCD display is turning on? However, another thing seems to have various settings that can be accessed by holding down the up and down button together for a few seconds, there's some kind of menu that I have no idea what it is etc.

    How do I fix this? could the controller be faulty? it was a cheap kit I got on ebay here

    I attached some pictures, thanks in advance.


    Ok so I have gotten the speed sensor working now, it shows mph when I crank the pedals. Still no movement on the motor though. I measured voltage across just the throttle and pedal assist sensors and they are both 4.2.

    The voltages across just the hall sensors is yellow 4.1, turquoise 4.1 and blue 00.7


      I fixed this myself....thanks for all the help.


        Hi, got the exact same bike and wanted to upgrade to throttle and lcd display, could you let me know how you did it please. I want throttle as as you know it doesn’t kick in straight away and I set off on hills so is not great, thanks