Announcement

Collapse
No announcement yet.

Can't communicate with Bafang Controller, please help.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Has anyone made this all work for Windows 10? We have tried almost every suggestion ( Com port less than 5, specific drivers, run as administrator, run in compatibility mode et al ). My son solves connectivity issues like this for a living, so I will update this once he has tried his magic.

    But, as of today, with five hours in, after I hit connect the boxes at the bottom are still grayed out.
    Last edited by Mel Tungate; 05-09-2018, 01:57 PM.

    Comment


    • max_volt
      max_volt commented
      Editing a comment
      Yes it works in 10. It was easy peasy. The driver should auto-load. Maybe you got a bum one.Can you see lights on the programmer?
      But like AZ recommended check and see what ports are available or maybe they got disabled. Baud rate too
      I have com port on the brain. I had one change from 6 to 7 somehow today but that was an actual rs232.
      How-about this, shouldn't windows make a ding noise when you plug it in, and dong when disconnected?
      Last edited by max_volt; 05-09-2018, 05:06 PM.

    • Mel Tungate
      Mel Tungate commented
      Editing a comment
      Azguy: mine is Com3, so that should not be the issue.

      Max_volt: red light comes on as soon as the cable plugs in. When I hit connect, a blueish light blinks on every few seconds, and keeps doing it for as long as I let it. Longest I tried was 20 minutes. Boxes on bottom all grayed out no matter how long I wait.

    • max_volt
      max_volt commented
      Editing a comment
      Are you running config tool v2 and have a solid connection to the controller with no bent pins and the battery is turned on?

    #17
    Max_volt: Your question was perfect, and led me to my error. So, I apologize for asking such a question, but the answer was “battery connections not plugged back in”. You have all heard the newbie excuses before, but I was working on the bike before I did this part, and ....

    So, I went out, made sure all of the battery connections were put back together, blushed when one wasn’t and tried it all again. Wala - worked perfectly.

    Than you both for your time.

    Comment


    • JPLabs
      JPLabs commented
      Editing a comment
      Mel, that's a problem I had, too! And needed to ask. I'm used to programming things like BattMan and the Satiatiator charger, which only need the USB power, as I recall. Programming controller when powered on seemed somehow risky to me or wrong, I purposely made sure it was de-powered. So, very understandable, IMO.

    • max_volt
      max_volt commented
      Editing a comment
      Nothing to be sorry about. You have to crawl before you can walk. Just be glad we have such a great resource as electricbike.com.

    #18
    I had this exact problem on a windows 7 notebook

    The Driver installed fine
    I Plugged the USB device into the notebook and the device showed up as installed properly in the device manager
    I Started the programming software and set the com port number to the same on shown in the device manager
    I Hit connect button
    The USB device blue light blinks on and off forever and controller info never shows up on screen.

    I was doing this away from the bike at the time in my office

    I saw the comment up above that the device may need power from the bike also besides the USB port
    As soon as I plugged the round BAFANG cable connector into the cable on the bike, the screen filled out and all was fine after that.

    Just confirming that in my case, the programming cable had to be plugged into the USB port AND the bike to work properly

    Comment

    Working...
    X