Announcement

Collapse
No announcement yet.

Can't communicate with Bafang Controller, please help.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • EL34
    replied
    I had this exact problem on a windows 7 notebook

    The Driver installed fine
    I Plugged the USB device into the notebook and the device showed up as installed properly in the device manager
    I Started the programming software and set the com port number to the same on shown in the device manager
    I Hit connect button
    The USB device blue light blinks on and off forever and controller info never shows up on screen.

    I was doing this away from the bike at the time in my office

    I saw the comment up above that the device may need power from the bike also besides the USB port
    As soon as I plugged the round BAFANG cable connector into the cable on the bike, the screen filled out and all was fine after that.

    Just confirming that in my case, the programming cable had to be plugged into the USB port AND the bike to work properly

    Leave a comment:


  • max_volt
    commented on 's reply
    Nothing to be sorry about. You have to crawl before you can walk. Just be glad we have such a great resource as electricbike.com.

  • JPLabs
    commented on 's reply
    Mel, that's a problem I had, too! And needed to ask. I'm used to programming things like BattMan and the Satiatiator charger, which only need the USB power, as I recall. Programming controller when powered on seemed somehow risky to me or wrong, I purposely made sure it was de-powered. So, very understandable, IMO.

  • Mel Tungate
    replied
    Max_volt: Your question was perfect, and led me to my error. So, I apologize for asking such a question, but the answer was “battery connections not plugged back in”. You have all heard the newbie excuses before, but I was working on the bike before I did this part, and ....

    So, I went out, made sure all of the battery connections were put back together, blushed when one wasn’t and tried it all again. Wala - worked perfectly.

    Than you both for your time.

    Leave a comment:


  • max_volt
    commented on 's reply
    Are you running config tool v2 and have a solid connection to the controller with no bent pins and the battery is turned on?

  • Mel Tungate
    commented on 's reply
    Azguy: mine is Com3, so that should not be the issue.

    Max_volt: red light comes on as soon as the cable plugs in. When I hit connect, a blueish light blinks on every few seconds, and keeps doing it for as long as I let it. Longest I tried was 20 minutes. Boxes on bottom all grayed out no matter how long I wait.

  • max_volt
    commented on 's reply
    Yes it works in 10. It was easy peasy. The driver should auto-load. Maybe you got a bum one.Can you see lights on the programmer?
    But like AZ recommended check and see what ports are available or maybe they got disabled. Baud rate too
    I have com port on the brain. I had one change from 6 to 7 somehow today but that was an actual rs232.
    How-about this, shouldn't windows make a ding noise when you plug it in, and dong when disconnected?
    Last edited by max_volt; 05-09-2018, 06:06 PM.

  • AZguy
    commented on 's reply
    Do you know how to use the windows "device manager"? You can force the port there.

  • Mel Tungate
    replied
    Has anyone made this all work for Windows 10? We have tried almost every suggestion ( Com port less than 5, specific drivers, run as administrator, run in compatibility mode et al ). My son solves connectivity issues like this for a living, so I will update this once he has tried his magic.

    But, as of today, with five hours in, after I hit connect the boxes at the bottom are still grayed out.
    Last edited by Mel Tungate; 05-09-2018, 02:57 PM.

    Leave a comment:


  • OhmsLaw
    replied
    I ran into the same issue this week with a home grown program that only goes up to COM10. I used the method in this link (to give credit where due). https://theitbros.com/how-to-delete-com-ports-in-use/
    I believe that a new COM port is used even if you plug the same device into a different USB port. I had duplicates of 2 3G modems and I know I plugged them in to different USB ports.

    Leave a comment:


  • JPLabs
    replied
    Hey thanks for that info. Worth bumping the old thread, for sure!

    Leave a comment:


  • espresso
    replied
    I know that this is an old topic, but after struggling to connect with the Bafang software on 5 different computers and trying everything I could find as a fix, I finally solved my connection problem.
    The Bafang software will only let you connect to Com ports 1-4.
    If when you plug in the cable to the USB port, it designates it to com 15 for example, it will not connect. It will give you a report - Error opening serial port!
    You have to look to see which of the ports 1-4 aren't being used, and then change the port number for the programming cable to that number.

    Leave a comment:


  • JPLabs
    replied
    Great, thanks for the tip!

    I like having the 33% speed PAS1, 45% current. PAS2 is the now the 44% minimum PAS speed it came with from Luna, which was previously PAS1. The rest are evenly spaced, just slightly adjusted to smooth out the steps. The low PAS1 is real nice for slow easy cruising.

    I finally tried asphalt today. I can pedal up to PAS4 on road, maybe 16 mph in top gear, great 'normal' riding pace, albeit fast spinning.

    Loving it still.

    Leave a comment:


  • markcycles
    commented on 's reply
    Yea having to run programs like that as administrator is standard. If you right click the program, click properties and then go to the compatibility tab there is a check box near the bottom "Run as administrator" that will make that automatic from then on

  • JPLabs
    replied
    Today I dried the cable on a Win7 machine, with drivers Windows picked (wch.cn CH340 3.1.2009.6). It worked, but only if I run Bafang program 'as administrator'.

    And, it works on my Win8.1 machine now, too, recognizing the COM port automatically. I'm using the wch.cn HL-340 3.3.2011.11 driver there. I had tried same yesterday with no luck on WIN8.1

    This is crazy. At least it's working now. Yay.

    I ordered another cable from a different source, which is supposedly direct from Bafang, to try also. In case this one keeps giving me trouble.

    I know I don't have a clear solution to post, and I'm sorry for that. But I hope someone can either find useful info here, or better yet, explain a more robust method. At least, be encouraged that it finally worked.
    Last edited by JPLabs; 02-27-2016, 10:18 AM.

    Leave a comment:

Working...
X