No announcement yet.

Sondors Battery or Controller fail?

  • Filter
  • Time
  • Show
Clear All
new posts

    Sondors Battery or Controller fail?

    So last week I repossessed my Sondors fatbike which was stolen 2 years ago. The thief never got the keys so the battery and holder were never removed. I honestly don't think it was ridden at all. The catch is I cannot get the LCD to register the battery level or activate the watts/motor, watttage shows as 0 and neither the peddle assist or the throttle will work. The LCD shows that the battery has 41 Volts and the voltage increases when I peddle but the motor will not go. I have a sondors thin original so I plugged the fat bike motor into the sondors thin system and the motor was good.
    I tested the throttle from the fat on the thin and it worked.
    I tested the fatbike lcd on the thin and it worked but it still did not display the battery level.
    I removed the brake connections to the controller on the fatbike and nothing happened.
    I plugged the sondors thin wheel onto the fatbike and it wouldnt go.
    I tested the sondors thin lcd and throttle on the fatbike but it wouldnt go.

    What I am trying to figure out is if it is a bad battery or if it is a failed controller that is causing the problem on the fat bike. I did remove the fatbike battery and correctly charged it. I tested the fuse and it is good. I checked the power level button on the top and it works. The terminals show 41 volts when tested. Any help would be appreciated. I am in the Boston area if anyone is local and wants to test my battery.

    I was told if I use the charger to test the battery I can eliminate the battery. How do I do this. Do I disconnect the controller from the battery and put the plugs directly against the charger end? Negetive on side and positive on pin? Or do I plug the charger into the battery and turn the battery on?