Announcement

Collapse
No announcement yet.

Sur-Ron - No Throttle

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Sur-Ron - No Throttle

    Hi Guys

    Just joined up as trying to fix a Sur-ron with a dead throttle, (bike powers on, wait & don't touch throttle, & still no throttle response)
    The details:
    Diagnostics lead is flashing as normal, (not showing any fault code)
    Battery is fully charged & fine (works in other bikes fine)
    Kick stand & brake sensors have been disconnected from day one (1900kms on the clock)

    I plugged in a new throttle & tested in my hand, it worked fine, then proceeded to remove old throttle & fit new one, after re-routing cable etc & fitting to handlebar, went to test again & nothing, same problem of a dead throttle on the new one fitted...

    Any help or ideas greatly appreciated
    Thanks in advance

    #2
    Originally posted by Fray Dogg View Post
    Hi Guys

    Just joined up as trying to fix a Sur-ron with a dead throttle, (bike powers on, wait & don't touch throttle, & still no throttle response)
    The details:
    Diagnostics lead is flashing as normal, (not showing any fault code)
    Battery is fully charged & fine (works in other bikes fine)
    Kick stand & brake sensors have been disconnected from day one (1900kms on the clock)

    I plugged in a new throttle & tested in my hand, it worked fine, then proceeded to remove old throttle & fit new one, after re-routing cable etc & fitting to handlebar, went to test again & nothing, same problem of a dead throttle on the new one fitted...

    Any help or ideas greatly appreciated
    Thanks in advance
    On my brand new Sur-ron, I find a dead throttle if bike is off for a while and I go to re-start. Sometimes I get the 14 flash error code, sometimes not. But I am finding the bike starts right up and the throttle works if the bike is started with the kickstand down after waiting 10-15 sec. So reinstall your kickstand sensor and see if that makes a difference.

    Comment


    • dirtman
      dirtman commented
      Editing a comment
      On my brand new 2020 SRX-LB
      A problem with my LS rear brake handle sticking cutting power.
      Simple fix. I had to learn to flick the brake handle to make the bike move.
      No big deal, something I learned to live with.
      Solution. Cut & taped the wiring to the LS rear brake.
      I didn`t cut the RS front brake cable in case of emergency shut off or if I ever need to install a rear brake light circuit.
Working...
X