Announcement

Collapse
No announcement yet.

No throttle response, where to start?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pascal
    replied
    It's been over 1 mounth since i had my my problem and no change so far.
    i will bring it to the thip to see how to fix it.
    I'll let you know the the conclu.
    Best....

    Leave a comment:


  • erectorsetsinc1
    replied
    I am having the same issue with throttle cut-out. This happened yesterday on a muddy wet ride. Did anyone figure out a good fix or did everything work normal after the bike dried out? Please respond

    Leave a comment:


  • EnduroJoe
    replied
    That stinks man, I'm a little nervous to wash the thing now.
    You tried the 4 safeties that kill the throttle- tip over, kickstand, front and rear brake. Hopefully you get it back rolling soon.

    Leave a comment:


  • Pascal
    replied
    Hey andurojoe,
    just to check, what do you call throttle killing safety?
    Is It the crash sensor that kills the throttle in case of fall.
    Black box behind the tontroller,?
    Best

    Leave a comment:


  • Pascal
    replied
    Hello,
    i did try without brake sensor, stand sensor, crash sensor.
    I did checked all connections and also the throttle box for the zero position.
    No change so far.
    I also did mount an other converter ( grey box next to throttle box)from my other sur ron ,: no change.
    The Thing that remains is the the controller....

    Leave a comment:


  • EnduroJoe
    replied
    Did you guys still have the brake sensors installed? I would start with the throttle killing safeties, brake sensors, kickstand sensor to see if water is somehow making the circuit.

    Leave a comment:


  • Pascal
    replied
    Hi,
    got exactly the same issue on my sur ron after washing.
    No high pressure washing just regular tab water.
    Everything works except throttle.
    Did check all connectors and sensos.
    Did anyone found the solution?
    Best

    Leave a comment:


  • anthonywebb
    started a topic No throttle response, where to start?

    No throttle response, where to start?

    We have been loving our Sur Ron x. My son was riding and parked it on the lawn to come in for lunch and the sprinklers came on and got the bike wet. After that the throttle stopped working. The battery appears to power up fine, as does the bike and lcd. But nothing happens when you turn the throttle. I have cycled the circuit breaker. Removed and reinserted the battery and still no dice. Can someone help me know what next steps are to diagnose the issue?
Working...
X