Announcement

Collapse
No announcement yet.

My m600 doesn't work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    My m600 doesn't work

    Hello
    i have a problem with my M600.
    After 800 km the engine does not work.
    The display lights up and the battery signal shows 0% when it is 100% charged.
    After 5 seconds, error 30 appears.
    cables are checked and ok.
    I don't know if the problem is with the controller or the display.
    Can you help me?
    Thanks in advanc

    #2
    I would guess the controller but its only a guess Other than that a lose or broken connection

    Comment


      #3
      I have tried the connections and they are fine. I will have to change the controller. The problem is that the dealer who sold me the motor does not supply me with the new controller. Very bad after-sales service. The only solution is to put a non-Bagang external controller. Can you help me with information about a new controller?

      Comment


        #4
        It could have just been the Display. Sometimes the Error Code 30 means that there is a malfunction with the display.

        Have you tried swapping with another one?

        If you have questions about setting up a new controller, I would be happy to help.

        Comment


          #5
          It may be a problem with the display.
          Do you know any compatible display?
          The one I have right now is DPC 240.CAN
          I'm in Spain

          Comment


            #6
            As far as I have experienced, all Bafang controller are compatible with their controllers since they use the some connector pieces. You should be able to browse bafang's website to select the one that you would like.

            Comment


              #7
              OK. I'll look for Bafang display.
              Thank you

              Comment

              Working...
              X