No announcement yet.

BBSHD controller? died, hard to push backwards

  • Filter
  • Time
  • Show
Clear All
new posts

    BBSHD controller? died, hard to push backwards


    I've had BBSHD just over 2 years and it has been perfectly reliable, it hasn't failed at all even when i sometimes abuse it hardly.

    It started some intermittent power cutting randomly couple weeks ago, after i washed the bike with hose (yes, stupid, i know), of course the battery was not installed.
    There was a little water in power cable and after drying, worked again perfectly like 300 kilometers.
    Couple days ago it started to work weirdly again.
    First gearsensor started to work intermittently, i disconnected that and after couple kilometers PAS stopped working in 1 and 3, worked like step 1 when in 5. Throttle worked flawless all time.
    I disconnected the battery and waited like 15mins, after that PAS worked again, until after like 10 kilometers it suddenly put 100% power with any PAS level. Again reboot, and worked rest of my ~25 kilometer trip.

    After couple hours stand, bike worked again perfectly about 20km trip to my friend, we had couple hours fun evening and when i started to go home, bike worked like 150 meters giving intermittent power all time. I stopped and disconnected everything, leaving just Eggrider and throttle, motor still not running.
    It started to "jerk" like 1/10 rotate of chainring every time i turned Eggrider on and no power to motor.
    When i got home I tried DCP14 display and it did show Error 12H, after that whole system cuts off when i push throttle/pedal and battery shows red/green leds, it just "jerks" that small movement to chainring and dies. I can turn whole system on, but it dies instantly when pushing throttle/pedal.
    Bike is also very, very jerky to push backwards, about 3-4 times harder than normally with BBSHD. Forward pedaling works normally.
    That jerky resistance when pushing backwards is weird, there is no power/battery in bike so broken controller should not be involved to that.
    Battery is ok, it works in my brothers BBSHD setup, but i think my motor/controller is broken..
    Any ideas what is broken?
    Last edited by Tofe-; 09-01-2020, 08:48 AM.

    Ouch, You may have two separate issues. I cant comment on the controller as I replaced mine almost immediately. But normally the issue rolling backwards is the plastic reduction gear. I just swapped mine to the Lunacycle steel replacement gear last night and Its not a hard job at all. From start to finish it was maybe an hour and a half and most of that was making sure not to strip any of the bolts.


      This is going more mysterious.
      I did disassemble whole system from bike to get it to table for closer inspection.
      Every wire and connector seems perfect, no bents, burns, broken insulate, nothing.
      I did tear down for motor and rotor, stator, every electronics, windings etc. looks like brand new, also nylon gear looks like it's not even used., no signs of water or rust anywhere.

      System turns on, but still no life in motor, i tried also with brand new controller, 2 displays (eggrider v2 and DCP14), and with 2 throttles, mixing them together, still nothing.
      New controller shows an error "30H No signal", old controller doesn't show any errors, both shows battery voltage right.
      Now it doesn't die when throttle is pushed, it just don't do absolutely nothing, not even chainring "jerk", also no more red/green over current leds in batterypack.

      I have no idea what is going on, i think i'll order new main harness, just to eliminate that fail option. If that doesn't help, i don't know what to do.
      Any ideas?


        Just my 2c, But it seems the Bafang controller is more trouble than its worth. Grabbing an aftermarket controller like the Phaserunner from Grin or Asi Bac 800 from ERT is gonna be well worth the extra money if you do end up having to replace the controller. I use the phaserunner personally and its a night and day difference, the motor is so much smoother and seems to run even cooler than the stock controller at stock wattage, even running 84v through it. The only issue is you would either have to get an pre configured bbshd file from someone, or program it yourself which isn't as hard as it sounds. If that isn't an option the ASI BAC from ERT would be your best option for plug and play. If you end up with the phaserunner contact me, I am more than willing to share my config files to make the process easier.
        Last edited by wireflyer; 09-09-2020, 07:09 AM.


        • Tofe-
          Tofe- commented
          Editing a comment
          Thanks for good tip with Phaserunner! It really does seem like a perfect controller with Cycleanalyst. My battery is capable to ~40amp continuous and BMS 50a, so I really think to get CA + PR.

        So, no luck yet, still not working.

        I bought a new motorcore with every electronics, stator, rotor etc. And also new main harness.

        New motor and harness:
        With that new controller, still error 30H, nothing more.
        With old controller, no error, just tiny tiny "tik" from motorcore every time throttle is pressed. Can be heard when listening carefully, feels better when motorcore is in hand.
        Tried every combo with 3 displays, always same results.

        Today, i drove to my lilbrothers carage and we tested everything with his BBSHD build.
        -Both of my displays work perfectly.
        -My battery works perfectly.
        -Both my harnesses works.
        -Both my throttles works.
        -With his harness and display/throttle: Old controller makes that tiny "tik"
        -With his harness and display/throttle: New controller, error 30H and nothing else.

        We didn't swap his controller, it was too much work coz bike is so much build around.

        Conclusion for 2 scenarios:
        1: Controller broke and did broke/burn motorcore or viceversa. When tested with new controller, burned it rightaway.
        2:Motorcore did broke and new controller was faulty already, seems ibvious because it didn't do nothing but error 30H from beging.

        Now I have only option to get another new controller to try, ill put my bucks for that. If no luck, ill order whole new unit without controller + phaserunner and cycleanalyst, new +50A cont. batterypack and make this bike a 3000wat beast.
        Then i'll solve this problem and build a BBSHD to my wifes MTB.

        I think this option is best for everyone, exclusive for me


          Okeydokey bike is running again and it was indeed a controller problem.
          I bought a second new controller and everything worked rightaway.
          That first controllers 30H error turned out to be a program locked fault, my local bbshd dealer got some patch of bbshd units and controllers which locks down if tried to program.? So no warranty for that 30H controller because i plugged it to Eggrider......
          sounds very weird IMO.....

          Anyway, fault found and bike runs.

          I did also buy a Felt DD30 fatbike, already ordered a bbshd + Phaserunner +60A capable battery and big pile of upgrade parts. Already installed Rockshox Bluto, Shimano M8000 brakes, dropper post etc.
          This is going to be epic build


            Wow, minor issues haven't soured you away from the sport. That does sound epic.


            • Tofe-
              Tofe- commented
              Editing a comment
              Thanks for nice comment. So far done 3 builds for myself and friends, none didn't were just bolton, coz akward mtb bikes... Learned a lot and i love BBSHD, no doubts best middrive system on the market.

            If anyone is getting 30H lock error because of trying programming. Let's take it to this topic:


              A torque sensor for the assist could be handy. More options to support the unit other than the triangle bracket would be nice. If they could also figure a way to make it mount a little tighter so we don't end up with the crazy chain lines that would also help a lot. There is a decent amount of metal on the back of the gear case that doesn't seem structural, you would think they could mill out a chunk there to help clear chain stays. Other than that I do think its a decent unit. I beat the crap out of one of mine today and I got it used and pre beat and its still going.


                Originally posted by Tofe- View Post
                If anyone is getting 30H lock error because of trying programming. Let's take it to this topic:
                Actually all you need to do is re-flash the controller. Just follow the instructions here: