Announcement

Collapse
No announcement yet.

48V 750W Bafang BBS02B Mid Drive is dead

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    48V 750W Bafang BBS02B Mid Drive is dead

    Hi,
    My 48V 750W Bafang BBS02B Mid Drive after 5 months of light use does not turn on. The 500C display was dead but after moving around and juggling the cables from main harness suddenly it turned on. That was to turn off again after a 20 minute ride and never came back to life. I tried to jumper PL with P+ and the motor started spinning using the throttle. After a while, messing with the cables for cuts or stress trying to figure out the issue, jumpering the PL and P+ didn't work anymore. It was at this moment that he knew he....:) maybe I fried the controller somehow. Battery outputs 50 Volt but when I get the voltage from main harness P+ it's 38V - 40V. Also I don't get anywhere 5V in the harness but instead I have 1V. In the end I opened the motor to access the controller and I checked the mosfets for continuity giving me all three (Green - Blue - Yellow) 10kΩ resistance on the ground side and infinite resistance on positive which I guess is a good sign. Also the motor does't give a resistance when I try to spin it backwards, which would be a sign of blown mosfets. So now I am stuck not knowing if it's the display, the controller or the harness cables. What does the low voltage output of 38V from the controller indicates? any help would be greatly appreciated!
    Last edited by tenekes13; 09-16-2021, 01:47 PM.

    #2
    No one has a suggestion?

    Comment


      #3
      Controller seems most likely. Displays tend to just be physical damage to the wiring.

      Comment


        #4
        Yes, this is what I was also thinking about. They will send me new harness wires and I will first replace these. I will keep you update

        Comment

        Working...
        X