Announcement

Collapse
No announcement yet.

Faulty programming cable?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Faulty programming cable?

    Hi, I've been riding with my BBS02 for 1 week now and really enjoying it.

    I thought I'd connect the programming cable supplied with the Luna kit to have a look at how the BBS02 is set up.

    Problem is, I can't get the BBS02 to connect using the programming cable. Pretty sure I'm following the correct procedure;

    Plugged programming cable into laptop running Windows 7 with USB driver installed.
    Disconnected 52V battery from BBS02.
    Plugged green programming plug into BBS02
    Reconnected 52V battery.
    Selected correct Com port in programming software (usually USB 8 or 9)
    Clicked connect.
    ...then nothing
    ...no information about BBS02
    ...no error message.

    I've tried a few times with different versions of the programming software and different USB port and USB drivers.
    It seems the laptop is communicating with the USB side of the programming cable but the serial side of programming cable is not communicating with the BBS02.

    Could I have a faulty programming cable here?
    Do I need to setup the com ports baud rate or parity etc in device manager?

    The BBS02 is running fine on the bike and the colour display works fine.

    Any help much appreciated!

    #2
    This happened when I initially tried to program my BBSHD. The COM port used by my cable is typically COM 5. You actually have to type in "COM5" for it to recognize the cable, don't just enter 5 in the box.
    If you are already doing this than please disregard and good luck!

    Comment


      #3
      This may seem obvious, but you need to have the battery connected --- and powered on (at least I do). I also then need to check in Device Manager to see which COM Port comes active and type that in to the box on the program screen and hit Connect.

      Comment


        #4
        Battery connected, power off, connect cable, power it on. LCD won't be on, but PC won't see it unless controller is powered on.

        Comment


          #5
          My experience may or may not be relevant here, but I thought I would pitch in. I only very recently succeeded (after many failed attempts with multiple PCs) to connect with my BBS02.

          What I did not know (being that I'm primarily a Mac user), is that the programming cable requires a DRIVER, and that this driver may or may not be automatically obtained by your PC. I had a difficult time figuring this out, with attempts to use the cable on four different PCs, and even a replacement cable sent from LunaCycle, before I was advised to look on these forums for a solution.

          The problem was that the cable never showed up under a COM port, always showing up as a "other device" in the device manager. This was true for my PCs running Window XP as well as Windows 7.

          On this forum, I first found mention of drivers needed, and some useful links:

          http://www.prolific.com.tw/US/ShowPr...id=225&pcid=41 <--- I used a driver from here for XP

          http://www.arduined.eu/ch340-windows-8-driver-download/ <--- a driver source mentioned for W8 users

          I successfully installed a driver on my oldest machine, a 2004 ThinkPad running XP, and then the cable showed up properly under a COM port. Finally I was able to run Penoff's program, and have happily made adjustments to my BBS02 configuration (mainly toning down the power of the PAS-1, and lower PAS levels, and also reducing the interval from stop pedalling to stop power assist).

          thanks
          Boris

          Comment


          • Peter Halt
            Peter Halt commented
            Editing a comment
            Yes, the driver allows your USB port to be used as a com port. It's an uncommon driver and won't be installed automatically.

          #6
          I have been having the same issue. The com port is setup correctly on Com3. The software sees the cable when I press connect but no information from the controller is seen and the read buttons are greyed out. Battery is on. Have you been able to figure out your problem? Did a new cable work? Just wondering if I need to send in for a new one.

          Comment


            #7
            I once connected a programming cable to a bike with the power on and fried the cable. It behaved like you are describing. Try a new one.

            Comment


              #8
              it sounds like you got a faulty cable..... email luna suport and we will take care of you.

              Comment


                #9
                Also try running the Program in "Administrator Mode" if the program does not have enough system rights it will not read the controller. What is your UAC setting?

                Comment

                Working...
                X