Announcement

Collapse
No announcement yet.

Dead in shed

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Dead in shed

    Bafang 750. Less than one year old. Rode ok a week ago. Went to ride but it is dead. No response to the button. Battery partially charged shows 52 v on meter. What next?

    #2


    In the Luna Knowledge Base there is a thread on BBS02/HD troubleshooting. That will get you started.

    This section

    https://electricbike.com/forum/forum...and-kits/bbshd
    Last edited by JPLabs; 07-30-2019, 09:59 AM. Reason: added link
    Fabrication is fun! Build something today. Show someone. Let them help. Inspire and share. Spread the desire.

    Comment


      #3
      Thank you so much for your reply. I was too stressed out to see where to start.
      Last edited by triplemaya; 07-31-2019, 03:17 AM.

      Comment


        #4
        Once you learn more, check back. Explaining what you find will help folks better help you, too, the checks described there will either show you whats wrong, or at least give you some answers to help decide what to try next.
        Fabrication is fun! Build something today. Show someone. Let them help. Inspire and share. Spread the desire.

        Comment


        • JPLabs
          JPLabs commented
          Editing a comment
          If it quit while sitting and battery is not dead, I'd tend to focus on looking for a connector that got pulled or chewed, first. Simple things that could happen handling the bike, or from critters. It could be as simple as a cable that got snagged or pulled from handling the bike....do a visual check before breaking out the volt meter. Make sure battery tight, all that.

          Good luck!
      Working...
      X