Announcement

Collapse
No announcement yet.

New BBSHD clicks madly and takes several pedal turns to engage after coasting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    New BBSHD clicks madly and takes several pedal turns to engage after coasting

    So I have a new DIY BBSHD setup with a Shimano 8speed IGH. About a 100 miles on it (3 weeks old). If I stop pedaling and cruise for a while, there is weird (so far intermittent) problem when I restart pedaling. The crank spins and clicks like crazy without actually engaging. After a few pedal turns, it behaves itself and I get forward push. I can't figure out if the issue is with the IGH or in the drive. The fact that it is intermittent makes it harder to troubleshoot.
    Does anyone have any experience with this particular glitch?
    Thanks!
    Rahul

    #2
    If you have a throttle and it works normally, I'd check the BBSHD's pedal clutch:

    BBSHD/BBS02B builds: IGH 1 2 3 4 5 6

    Comment


      #3
      Thanks for that tip! Throttle works fine. We'll look at the clutch. It's a brand new Luna Cycle unit so probably got a lemon of some sort in there. Maybe just call them and moan about it.

      Comment


        #4
        Problem solved! Clutch was fine. Cable connecting to IGH was *seriously* out of whack. My bike guys dismantled and reconnected the IGH cable and reset the hub. All slippage went away. I asked why it felt clicky and clanky up front and their considered reply was "When this happens everything feels... f***ky."
        Moral of story - check the drivetrain before dismantling the drive.

        Comment

        Working...
        X