Announcement

Collapse
No announcement yet.

BBSHD not starting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    BBSHD not starting

    Hi guys,

    Ordered my kit from China a few weeks ago and after it all finally arriving I went about putting it together today.

    Low and behold, come the big switch on, I’ve got power to the display but no throttle, and no noise from the motor at all. I’ve had a quick read around the forums and looks like first check should be the battery.

    So I’ve ordered a multimeter but have no idea what I’m checking and looking for. It’s a 52v 21AH battery, what reading should I be checking for and what readings should I be expecting.

    Also while I’m here I’ve got a DCP-18 display, I’ve noticed when trying to setup the hydraulic brake sensors there is no symbol on the display for the brake, am I correct in saying this display does not show the brakes? If so I need to get the motor going so I can listen for the brake cutting the motor.

    Sorry for the essay but thank you to advance for any advice you could give me.

    #2
    I have the same situation

    Comment


      #3
      Disconnect the main cable that leads to all the others like display, brake sensors, shift sensor, throttle. Connect display and throttle - see if motor starts. If motor starts, connect shift sensor. then brake sensor. It is likely that your brake sensor may be cutting off your motor

      Comment


        #4
        Hi guys. Completely forgot about this post. So I actually found the problem! Turned out it was a faulty brake sensor, ordered a new one the other day so going to fit it this weekend. But as soon as I unplugged the faulty one the motor started working.

        Comment


          #5
          I have similar problem,, have a BBSHD with a SO39-3 52 volt battery,, battery has charge but i am getting no power ,, motor w=nor display will work,, simply no power,, what did I miss?

          Comment

          Working...
          X