Announcement

Collapse
No announcement yet.

Brand new BBSHD kit installed but no power from motor

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 73Eldo
    replied
    Very strange. Seems like others have swapped back and fourth and only real issue is the battery gauge isn't accurate and you may not get optimum range. Don't think I have ever heard of it just not working. Was there any sort of error message on the screen? I could maybe see it giving an over volt message even though I never heard of it before. That is one annoying thing about the BBS line, there are a ton of hardware and firmware versions out there now and it can be really hard to tell what you are getting. A larger seller like Luna seems to know or have slight control over what they get and sell but I would imagine smaller sellers just get what they get.

    Are you sure this is the 'old' BBSHD and not the latest version? The newest version has a little sleeker look to it and the eye/hole in the motor housing you an use to brace it to your down tube. The new version officially has to be paired to an official Bafang battery. Have not heard what happens if its not or if people have found a way around that yet. I have seen that people have been able to put an HD controller on em so that is one route.

    Leave a comment:


  • lionelbyron
    replied
    Display is working. Turns out problem is controller is 48V and battery is 52V. Returning motor to dealer for him to update controller.

    Leave a comment:


  • 73Eldo
    replied
    I assume the display is working? Maybe post a screen shot of that so we can see if there is anything unusual showing up there.

    Leave a comment:


  • Brand new BBSHD kit installed but no power from motor

    I've just completed the install with the BBSHD kit (with DPC 14 display) and a UPP 52V 20aH battery. Battery is fully charged. I've tried disconnecting both brake and gear shift sensors. Still no power from the motor. Any advise would be greatly appreciated.
Working...
X