No announcement yet.

Did I just fry three controllers?

  • Filter
  • Time
  • Show
Clear All
new posts

    Did I just fry three controllers?

    1. Last saturday I fried my bbshd controller. I wasn't going fast but it died good and smelled of burnt sulfur.

    2. Yesterday I bought a brand spankin' controller off a friend who had an extra. Connected it up and got the error 10, which indicates that the temperature sensor was tripped earlier. I used the firmware update workaround but after it took the display wouldn't turn on. When I first connected the power on the anderson cables, there was a healthy spark. But after the fix, no spark at all even though the line reads a normal voltage (54v). This makes me think something inside is getting blown because a full circuit can't be completed.

    3. On Monday I ordered a luna barebones system (motor + controller) so I could ensure there wasn't something bad with the motor. It arrived today. Diligently I connected everything up. As before, first a spark, but when I tried the display (two displays actually--I have a backup) it wouldn't turn on. Now when I try to reconnect power there again is no spark.

    Did I just ruin three controllers in a week? Please, what might be wrong or how could I isolate the issue? I'm at a complete loss and my livelihood depends on having a working bike.
    Last edited by LonnieRay; 10-14-2022, 05:55 PM.

    Anything could be wrong. Pics can help of what you are doing. I cant tell what you mean when you say the line is normal 54v. Is it connected to the motor when you read 54v or is it disconnected when you measure it. Do you have a meter on the voltage when you try to power up the display? Does the voltage have a reaction when you push on the throttle? So need more detail about what you are doing. And post a bunch of pics too. Especially since something smoked. Battery connection pics, cable connection pics, and how you have the bare bones situation hooked up. It dont have to be on a bike to run for testing. And what kind of battery do you have? Lots seem to malfunction without much abuse. Especially the low Ah ones.


      I feel like the biggest clue is that there's no spark when I connect the anderson conectors when the first time I DID get a spark. What would that mean?

      As for your questions, I have a fully charged 48v battery that is reading 54v off my multimeter. It's a 30ah 48v li-ion battery that has been working just fine. I have a second one as well but the problem is the same with either one. It can be connected or disconnected to the motor and still read the 54v, but this is all before it enters the motor.

      Nothing can be read from the the display.

      I also can't connect to the system via the programmer cable and laptop anymore.

      I have bbshd#2 on the ground and just connected to cables, so yeah it's not on the bike for testing. But it seems like I did the same thing to it. I'm at a loss and don't know what to try now.
      Last edited by LonnieRay; 10-14-2022, 07:16 PM.


        The spark means the capacitors in the controller are working nicely. They would only spark once. Then the next spark time is dependant on what makes the caps discharge. If very little, then the caps will stay charged for awhile. If the controller has short like damage, they will spark again pretty quickly.

        So old controller fried on a big battery. So the wiring will no doubt be stressed. New controller kinda worked with error until you did a firmware update. Then it quit. No spark even. Then you got a new mid drive unit and you got no spark on that either. Hmmm.

        OK, unplug the display. The Bafang will run without the display. It defaults to a low PAS and your throttle should spin the motor. If it does then plug display in and again try the throttle.


          It DID spark the first time on the new mid drive unit. And never again.

          I'm getting voltage out of some of the pins on the wiring harness though, so power is not completely blocked. I'm not sure the best way to check to probe where the problem might be.

          I can't connect through the programming cable. No connection can be made when I try with the bafang programmer tool.

          The motor does not spin when I did what you tried, running without the display. There's no instance where I can get the motor to spin. The new middrive unit never spun the motor once. The new controller did not either. Don't know what to try next.


            I powered mine up on the floor. Motor, throttle, and some voltage lower than 48v Roughly 44v. Connected the PC UART device and running PC software too. The software only works when the motor first powers up. Then it goes into ready for throttle. So the pc software parameters are set like it says in the software instructions. Then I push Check MCU at the bottom left on the PC. And it sits there saying "checking target MCU". Then I plug power into the motor and get a big spark. Then all the motor controller info is suddenly displayed in the PC. Then I push on the throttle and it runs the motor. That's what a brand new motor never installed does. Mine is a BBS02 new version controller. I'm sure its the same but less powerful. Runs on the same displays. Your new motor has to at least do that.

            I don't have brakes, speed sensor, or shift sensor hooked up. Just motor, throttle, UART cable, and power line. I will have to get one of those anti spark connectors. At the least, the sparking will wear out the power connector over time. The factory should have added anti spark to the motor but it is what it is.
            Last edited by stts; 10-15-2022, 01:20 PM.


              Did you test your battery ?