Announcement

Collapse
No announcement yet.

750c Display Documentation

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • paxtana
    commented on 's reply
    As stated in the video on this document, not all options are available. These options require a bms capable of communicating with the display, this does not currently exist yet.

  • dwturbo70
    replied
    How is the range option operated. Also,in the battery informations screen, how do I enable the battery cycle, temp, health, and capacities. Thanks in advance!

    Leave a comment:


  • paxtana
    commented on 's reply
    21 is a speedo error. Usually caused by improperly installing the magnet too far from sensor.

    https://electricbike.com/forum/forum...ouble-shooting

    https://electricbike.com/forum/forum...-for-the-bbsxx

  • BMundo
    replied
    My brand new bbshd and 750c is throwing a 21H error (unknown error). The symptom seems to be that when I engage the throttle the power reading spikes all over the place and sometimes spikes and then goes to zero. Any idea what might be the issue?

    Leave a comment:


  • MPieczko
    commented on 's reply
    Anyone know what gauge wire is used for the button to display; assume its 1 or 2 wires, possibly 3.

  • paxtana
    commented on 's reply
    It is not removable.
    You might be able to cut and splice, I do not recall anyone doing that though. Probably just want to make sure you're not shorting anything when cutting it and that you wire up the same wires to the corresponding wiring when splicing in the extra length.

  • MPieczko
    replied
    For the latest 750c, is the cable between the button control and the display removable, and is it 5 conductor (green) or 4 conductor (blue)?

    I'd like to do a stealth install with the display in a bag under seat with battery and then remote route the cable to the button control on the bars. I figure I have to go this route since the DPC-14 the 750c is based on does have a removable cable to the button control, just not sure if the Luna version does or not. If it does not have a removable cable, then how does the button control wire mount to the display and can it be spliced longer?

    If it were possible to just extend the 961 cable between the button control and display I'd go that route - any thoughts either way?

    Leave a comment:


  • paxtana
    commented on 's reply
    Glad to hear the good news!

  • teammixa
    replied
    Swapped controllers from a good bbshd I have and it works and the motor sounds great again. I guess if anyone comes across a 0CH its definitely a fried controller.

    Leave a comment:


  • teammixa
    replied
    I pulled the controller check all the wires and still the same error after reconnecting. I happen to have another controller so I'll swap those and see what happens.

    Leave a comment:


  • paxtana
    replied
    Maybe. You probably want to pull the controller at this point and have a look at the wiring. Hopefully it's just a loose connector between controller/motor.

    Leave a comment:


  • teammixa
    replied
    Here is the pics showing the Error 0CH. When I hit the throttle while the bike is on the stand the Watt meter spikes to 1100+ watts which never happens while on the stand. Definitely something wrong. I bought this kit back in June from Luna. Bypassing the display would only mask the issue, I would think. I did swap out display's as I happen to have another 750c display and that one also gave the same error so its not the display that's the issue. If the 0CH is hex then Hex C would be 12, so according to the error code list, maybe a current sensor error? Seems like that could be the case given how its behaving.

    Leave a comment:


  • paxtana
    commented on 's reply
    Can you take a pic? Is it recently bought? Have you tried bypassing display using program cable.to see if issue persists?

  • teammixa
    replied
    Anybody know what a 0CH code is on the Luna 750c display? Bike was still on but wouldn't push out any power and was super sluggish. After trying later in the day it worked but after sitting over night the code came back. I noticed from my amp meter the amp draw was jumping all over the place and acting very inconsistent which has never happened before.

    Leave a comment:


  • max_volt
    commented on 's reply
    The Aussie accent is difficult for many to understand.
Working...
X