Announcement

Collapse
No announcement yet.

M600 Troubleshooting

Collapse
This topic is closed.
X
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #2
    Error codes, If you see and error code on your display please refer to this list.

    Click image for larger version  Name:	M600 error codes.png Views:	0 Size:	191.8 KB ID:	141541

    Some of these errors are just a fault that can get cleared off with a simple pause (like over heat) some may require you to restart, some might need more than just a restart.

    Here is a few explanation on the common error codes
    • Error 4, throttle is likely broken, unplug to see if the error clears up, if it does then replace it
    • Error 10, 14, 15, this can happen if you lug, abuse the motor, specially the Ludicrous version, avoid climbing at full throttle in a high gear (small cog) *see note below*
    • Error 12 possibly a bad connection or a controller issue, please check the battery connection up to the motor and also unplug your main harness and plug it back in (see post below on how to plug in the motor correctly.
    • Error 21, speedo sensor alignment (see picture below on how to align) speedo damaged, speedo unplugged (there is an extension on the speedo sensor so make sure to check both connections), Note: the motor will shut down after a few seconds if you get error 21. UPDATE: IF you don't have any speed reading (after adjusting it) and don't get any shutdowns while riding then it's likely a controller fault, please contact Luna with your order number.
    • Error 25, not that this is common but it's possible that the sensor is out of calibration or that the controller or sensor is damage, if you have a BESST you might try to calibrate it, it's worth a try if you have one. IF you don't have one you would have to send the motor to the shop.
    • Error 30, IF you are experiencing cut outs, error 30 or complete shutdown please click this link or scroll down to the wiring section, the vast majority of error 30 are the connection of the wiring that is damaged, start by inspecting all connections as per the guide below and then replace the main harness (click here)
    The M600 is a small motor.. very small but packs quite a punch so it's quite normal that it will gets hot faster than a bigger motor (Like a BBSHD for example) or compared to big brand name motor that is the same size but 3x less power. So avoid using high PAS assist or high level of throttle for a long time (either climbing a mountain or lugging the motor into the wrong gear) or you will get the motor very hot and trip the controller into limp mode (the motor will get weaker) and then it will shut down into an error code. Lower the assist, pedal harder, change gears to a higher pedal cadence... your motor and also your battery will thank you.

    Speedometer alignment for error 21:

    Click image for larger version  Name:	speedo.jpg Views:	0 Size:	132.5 KB ID:	141555
    Last edited by Sebz; 09-08-2021, 09:39 AM.

    Comment


      #3

      Display does not power up
      Display powers up but shuts down right away.
      Motor & display shuts down while riding


      1) The battery


      The battery is not the #1 culprit but you should rule it out first, the terminals can be loose, the connector unplugged and such. This is a X1 battery (yours can differ), showing a standard led power readout, on/off button, and barrel charge port. Make sure that the power button is pressed in and lighting up. Remove the battery and inspect the terminals. for advanced battery troubleshooting on the X1 please click here to visit the x1 manual

      Click image for larger version  Name:	x1_spare_battery__34932.1605734489.jpg Views:	0 Size:	302.8 KB ID:	134419

      2) Display connections:

      2x connections that goes into the back of the display needs to be shoved in really hard, you should hear and feel a click or a pop, if you are having trouble turning it on be sure to check this and the other connectors. Recommended to unplug the connector before firmly plugging it back in.

      Click image for larger version  Name:	image_18338 (1).png Views:	0 Size:	172.4 KB ID:	134420


      On the DPC-240, you will need to push them in hard and make sure that they are perfectly aligned, there should only be a 2mm gap between the display bracket and the line on the connectors.

      Click image for larger version  Name:	image_23920.jpg Views:	0 Size:	1.16 MB ID:	134421Click image for larger version  Name:	image_23921.jpg Views:	0 Size:	1,009.0 KB ID:	134422

      The gap between the bracket and the connector line should be 2mm, if it's not 2mm then take a long nose plier and grab the connector body and push on it (click here to see) . DO NO PUSH ON THE WIRES AT THE TIP OF THE CONNECTORS.

      Click image for larger version  Name:	image_23922.jpg Views:	0 Size:	1.18 MB ID:	134423


      3) The motor main connections.

      Remove the 2 allen head bolts that secures the bash-guard under the motor. On the left side of the motor you will find a plastic plate with 3 torx T10 screws, remove that plate to expose the connections. No need to remove the motor!

      Click image for larger version  Name:	image_22890.jpg Views:	0 Size:	487.8 KB ID:	134425

      On the far left you have the main harness multipin connector, the middle (purple) is unused on the right one is the speedometer. Please check these 2 it's possible that one is halfway out an giving issues. Unplug, then press them in firmly, like the display connections. For an example of this solution see this page.

      On on the far right you have the battery main power lead (yellow XT60), you can unplug this one and measure the voltage from the battery to be sure that you don't have a bad connection. With the power button to ON, you should be measure anything from 38V to 54.6V. (Again you don't have to remove the motor from the bike you can do all this with the motor on the bike)

      Click image for larger version  Name:	image_18292 (1).png Views:	0 Size:	2.44 MB ID:	134426

      Tip: You can use a long nose plier covered with tape to push in the connectors into the motor., The connector should have a 4mm gap between the case and the connector line.

      Click image for larger version  Name:	image_21767.jpg Views:	0 Size:	844.6 KB ID:	134427Click image for larger version  Name:	image_23923.jpg Views:	0 Size:	1.23 MB ID:	134428

      Last step, swapping parts:

      IF you test the battery and you know it works and checked all the connections then it can be the display, the main harness or the controller. If you would like to avoid removing the motor and send it back to the shop, we recommend you to order a spare main harness and display. The display takes seconds to swap but the main harness is not so simple .. but you can totally runt he spare main harness outside of the frame for testing purposes. If it's indeed the main harness then follow this easy trick :

      How to fish a new main harness in a X1 frame or any internally routed frame.

      With the motor fully removed , tie dental floss or shift cable (or any flexible small cable) to old harness at display / throttle plug , pull from bottom and remove old harness leaving guide wire in the frame . Carefully tape or tie guide wire to new display /throttle plug and push / pull gently til plugs come out of hole, be careful not to pull too hard. The junction where the throttle /display split it too big to fit thru frame hole so it stays inside the frame.
      Last edited by Sebz; 2 weeks ago.

      Comment


        #4
        Display lights up but motor is stuttering/hesitating or it run very poorly and gets hot really fast?

        This is possibly due to the magnet at the tip of the rotor shaft that came loose. This magnet is a special magnet, the polarity is very different than your regular fridge magnet, it's got lateral poles so when the motor is turning the controller can pickup the changing magnetic field and know when to send the power. If the magnet has moved then the controller will run very poorly.

        To fix this you need a BESST tool, you will need to pull out the controller to unplug the 3 pin large XT connector (blue, yellow, green wires) and the temp sensor connector (2 black wires with white connector). Then you will have to remove the motor core out from the left side of the motor casing (3x Torx head).
        At the tip of the shaft you will see a magnet, if it's missing look inside the motor it's not far. Glue that magnet in place using super glue, if it's greased up you will have to clean it good before applying glue.

        In the picture below you see the 2 connectors that you need to unplug and also you can see the magnet at the tip of the rotor that has moved out of it's place.

        Click image for larger version  Name:	image_24930.jpg Views:	29 Size:	827.2 KB ID:	134416

        Complete video on how to open the motor and fix the magnet



        Next step will be to re-install the core and and then calibrate the motor using the BESST

        This is the video on how to use the BESST. WARNING: Do not plug the display into the BESST while calibrating the motor like you see in the video.



        Alternate video on how to calibrate the motor:



        If you can't do all this email us a support@Lunacycle.com and we will help you.
        Last edited by Sebz; 08-30-2021, 04:56 PM.

        Comment


          #5
          Motor removal and installation

          This is a Luna X1 bike, yours might be different but the mounting is the same on all the frames using the M600 motor mount.

          You will need a Allen key set
          A T10 Torx screwdriver
          13mm wrench or thin walled 13mm socket
          Optional : a large flat head screwdriver or a chainring tool (to hold the back of the chainring bolt)

          Motor removal


          Motor installation


          To remove the chainring bracket (AKA Spider) from the motor (if you must open the motor for service):
          This is recessed so a typical ring spanner will not work. A socket style bottom bracket tool for screw in bearing cups does the job. This tool will work: Bike Hand YC-29BB-2A as well as YC-29BB. Bafang socket tools will also work. A chain whip is needed to hold the chainring when removing the locking nut. The lockring is reverse or right hand-threaded, so you must turn it clockwise to remove it.
          Last edited by Sebz; 08-30-2021, 05:45 PM.

          Comment


            #6
            Mechanical problems / noises

            The M600 is not the most silent mid-drive motor out there (if you are used to a BBSHD of a factory big brand 500W middrive unit then it's pretty apparent) but adding the silent gear (PEEK plastic) does help out tremendously .. that being said it's still not the most silent motor. Now if you are inquiring why the motor is louder when you lift up the rear and let it rip unloaded, rest assured it's normal it is louder unloaded than when you actually ride the bike. As you ride it during the first 100 miles or so it's possible that the noise level change a little as the gears gets broken-in and grease shifts around. So give it at least 100 miles or so before thinking or opening the motor or sending it in for repairs.

            Video on how to quickly diagnose mechanical issues ,



            Video on how to open the gearbox and swap the clutch or the peek gear.



            Another video on how to open the motor and change the PEEK gear if you missed something in the second one :



            Video on how the gearbox works:



            WARNING: If you decide to open up the motor, please be aware that you cannot turn the rotor, if you do the controller will loose the position of the rotor and you will have to calibrate the motor to the controller using the BESST, see picture below of what you must not touch!

            Click image for larger version  Name:	Screen Shot 2021-08-25 at 10.43.43 PM.png Views:	30 Size:	938.1 KB ID:	136151


            We will cover some of the issues but not everything as not all the parts can be ordered online.. yet. We can always fix your motor if the part is not available online so keep that in mind.
            Last edited by Sebz; 08-30-2021, 04:53 PM.

            Comment


              #7
              Maintenance / Greasing

              We recommend to use MobilGrease SHC100 as the thickeners are compatible with the stock grease, if you don't have it make sure that it's compatible with moly grease, if you are using Mobilgrease28 or any other that you are not sure best would be to thoroughly clean all the gears first.

              If you rip any of the gaskets and are in a rush out can always make your own with some RTV gasket maker, ok fix your paper gasket with a touch of glue, RTV or silicone



              Video on how to open the gearbox and swap the clutch or the peek gear.



              Another video on how to open the motor and change the PEEK gear if you missed something in the second one :



              Another video on how to grease the M600:



              Video on how the gearbox works:



              WARNING: If you decide to open up the motor, please be aware that you cannot turn the rotor, if you do the controller will loose the position of the rotor and you will have to calibrate the motor to the controller using the BESST, see picture below of what you must not touch!
              Last edited by Sebz; 08-30-2021, 05:05 PM.

              Comment

              Working...
              X