Announcement

Collapse
No announcement yet.

X-1 / M600 BESST Firmware Programming

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    X-1 / M600 BESST Firmware Programming

    I received my BESST reprogramming tool today. Thanks for making it and the alternate firmwares available! I had a couple questions and I know other users (like eskachig and @richcapone) will have this tool as well, so I figured I'd start a thread about using the tool and people's experience with the other firmware options.

    I figure we'll start with the easy questions - I received the tool and the instructions in the form of the sticker below. But when I log into my account, I can't find an option to download Luna BESST software or the firmware files?




    #2
    Downloadables on the listing still needs work, try this attachment it has everything.

    ..edit as to your question since I am removing this file later, it will have been emailed to you in the delivery confirmation email.
    Attached Files
    Last edited by paxtana; 11-30-2020, 11:13 PM.

    Comment


    • UCR1
      UCR1 commented
      Editing a comment
      That button is not there

      https://imgur.com/IZQTvad
      Last edited by UCR1; 12-04-2020, 08:38 PM.

    • paxtana
      paxtana commented
      Editing a comment
      If the button is not there, you may not be using the proper application version, or you allowed it to auto-update to a later version. The one attached to my post is the correct one. It is not the latest one, it is 1.2.18

    • UCR1
      UCR1 commented
      Editing a comment
      I havent let it upgrade, even tried reinstalling with the wifi disconnected. Used the download from the email and the download from your post here. Maybe the BESSTdevice has to be plugged in for that offline button to show up?

      https://imgur.com/RoJzQ1v
      Last edited by UCR1; 12-05-2020, 02:42 PM.

    #3
    Just ordered mine as well. Does it have the ability to download the existing firmware from the bike? (i dont think I would need it since in theory ill get the same in this bundle?) Excited to try it out on both mine and my wifes X1s

    Comment


    • paxtana
      paxtana commented
      Editing a comment
      It does not have the ability to pull the existing firmware from the bike.

    • UCR1
      UCR1 commented
      Editing a comment
      Cool thanks, the 3 in this bundle are the only 3 Luna has ever shipped? Do you know what the plans on for future firmwares? (will they be made available for older bikes if we buy the programmer?

    • paxtana
      paxtana commented
      Editing a comment
      No idea. It has the Luna custom firmware that is shipped with Luna bikes, and it has the stock bafang one that some people prefer. I do not know what the third one is. Maybe the most recent bafang firmware version, or maybe an older luna version.

    #4
    Mine's in the mail, looking forward to trying it out. The 46.6 version in the zip file that paxtana posted is kind of an odd duck - it was emailed to me by bafang after I described he issues with low power at low PAS and then they stopped talking to me. A user at endless sphere actually did install it on his bike, and then ended up going back to the stock 14.6 - which is the one I'm planning to install on my own bike.

    I'm going to quote his posts for reference, I don't know that anyone else has tried it yet.

    I installed the firmware and first impression is very smooth, lots of assist power in level 1 and 2. Throttle seems smoother and easier to control
    Assist power is very smooth as pedals are pressed with exception of starting from complete stop. There is a substantial jerk as pedals are pressed.
    I have been riding with 14.6 firmware and this new firmware gives a lot more assist in level 1. I would say that new level 1 feels “stronger” than level 2 in 14.6 version. With 14.6 I had work hard while climbing in lvl 2 and now same climb in lvl 1 feels easy. Also on flat trail sections I have to go to 11th gear to feel any effort in my legs. Motor is doing a lot of work. Good news is that power comes in very smoothly and in predictable fashion and not like in 14.6 firmware. Bad news is that bike feels like there is way too much assist in level 1. I’m not exaggerating when I say new lvl1 feels stronger than lvl 2 in older version. Of course this extra power comes at price of battery range. On same ride I used to come back with 35% battery left and this morning I returned with 8%.
    Anyone else install new version? What are your experiences?
    After several rides i was planning to return to 14.6. I could live with uneven assist for the price of range and not having a scooter for mnt bike. I hope that 14.6 here works. Has anyone installed it?
    Also, I installed m500 firmware and it seems very “overboosted” in lvl 1 but not as much as newest firmware. As CiDi mentioned, battery level is not accurate and battery will be depleted to very low voltage if one is not being careful. Mini voltmeter would be handy if one was to go on a long trip.
    The new firmware is very very smooth, but just too strong. If bafang was to decrease power in level 1 by 50% and 30% in level 2 then this would be incredibly nice.
    Good news is that 14.6 firmware posted by Artyy on Sep 3 works. I reinstalled it and bike works fine.

    I forgot to mention, in 14.6 there is a noise from the motor as I'm pedaling in lvl 1. I'm guessing, but it seems like I'm overrunning the sprag clutch. This noise was not heard in new and 43v firmware. Only once in a while when I shifted to smaller cog.

    It would seem that there are plusses and minuses to new firmware.
    Noise and uneven assist for having to pedal and having increased range in 14.6.
    Quiet and smooth for easy pedaling and shorter rides in new versions.
    https://endless-sphere.com/forums/vi...0777&start=400

    Almost sounds like another Bafang custom one-off.

    Comment


      #5
      @Desmodromic. So I am finally digging into my BESST tool. Had to get a windows laptop to get started! It requires a login? Did you get a login pw when you bought it from Luna? I tried my luna.com login pw but it didn't work.

      Comment


      • paxtana
        paxtana commented
        Editing a comment
        You don't need a login, there is a button for offline mode on that login screen

      #6
      For folks having issues with seeing how to login offline, the video below shows all you should have to do. If you don't see it after doing this, try a different computer.

      Comment


      • Desmodromic
        Desmodromic commented
        Editing a comment
        Thanks for sharing the walk-through video paxtana - super helpful.

      #7
      Thanks for this video. I followed it and installed 1.2.18 BESST and I don't have a gray "Offline Mode" button below the orange "Log in" button. Maybe you have to have logged in before successfully before it will give you an "offline" option?
      Click image for larger version

Name:	IMG_2009.jpg
Views:	1430
Size:	2.56 MB
ID:	118711

      Comment


        #8
        I just tested that theory on another machine and it appears you are correct. I will let our shop know so we can fix it. In the meantime here's a login. I would highly advise after using it to close it out and use the offline login once it shows up. Using any online options through this account (such as auto-updating software, firmware etc) may not end well, doing that is not recommended.

        edited: contact for password
        Last edited by paxtana; 4 weeks ago.

        Comment


        • SDebike
          SDebike commented
          Editing a comment
          Please let me know how to get the off-line mode with the BESST home page. I can't get it to show up. I've tried many times. Very frustrated.

        • paxtana
          paxtana commented
          Editing a comment
          Bafang deleted the login publicly posted here. For an alternative login PM me or email support!

        • Mike_V
          Mike_V commented
          Editing a comment
          Luna team eMail support provides excellent, personalized guidance.

        #9
        Thank‘s for help, I was able to login and after re-opening the BESST home page the offline button is shown.
        Attached Files
        Last edited by KaroKönig; 12-07-2020, 08:46 AM.

        Comment


        • SDebike
          SDebike commented
          Editing a comment
          How did you log-in?

        #10
        Nice. Glad to hear it!

        Comment


          #11
          Thank, I was able to upgrade my X1 Lud firmware! I tried the stock bafang and it was definitely too jumpy. With a ludicrous X1, barely touching the pedal in PAS 1 makes the bike jump. I loaded the stock X1 and will try later today on a real ride. But I did test out the stock X1 firmware, up the hill in front of my house and it feels a lot better. PAS 1 and 2 are not under powered.

          Comment


          • paxtana
            paxtana commented
            Editing a comment
            Oh I am not Eric, just the customer service manager. I do not have all the info but am trying to make it as easy as possible for yall to give these things a try. At this point some of you probably know more than I do, if trying all three firmwares that were made available.

          • K442
            K442 commented
            Editing a comment
            lol - oops...looks like fingers were typing faster than brain was processing. Appreciate all your help in sorting this out, paxtana!

          • eskachig
            eskachig commented
            Editing a comment
            Ludi - version of the bike with the customized Luna controller that puts out more power.

            Stock x1 firmware - 14.5 - custom Luna firmware with less juice at low PAS and some other improvements. Imo, feels gimped on the stock x1, but might be perfect for Ludi.

            Stock Bafang - 14.6 - default Bafang firmware, might be jumpy on a ludi bike, but if you have a standard x1 and want to climb in low PAS, this one will get you up the hill.

            43.3 - some weird Bafang version, reported extra smooth, but also a bit overcharged at low PAS.

          #12
          That work around worked for me as well - offline showed up after logging in with Rodney's login. Thanks guys! Glad it wasnt on my end. Now if I can figure out a way to keep windows from spamming me about trying to upgrade to 1.2.25!

          Edit: C:\Users\YOURUSERNAME\AppData\Roaming\BESST\_updat e_

          This folder seems to be the ticket. Delete the contents of this folder, and set all permissions for the folder to DENY.
          Last edited by UCR1; 12-07-2020, 07:52 PM.

          Comment


            #13
            Ordered my BESST tool tonight, downloaded all the files. Hoping things will be well sorted by the time the box arrives!

            Comment


              #14
              here is a good option https://endless-sphere.com/forums/vi...0777&start=400

              Comment


                #15
                Just did my first ride... went from the 14.5 Luna firmware that came on my bike, rode it, then upgraded to 14.6 and immediately rode it. 14.6 is better. I use the 9 assist mode option, and 1-9 are all usable. Before I needed to really press hard to get 1-4 to work (or 1 and 2 in the 5 mode option). I prefer 14.6 for sure.

                I should also mention mine is a ludi bike. Really happy with this purchase.

                and the Easter egg no one is talking about... we can change our tire size, wheel circumference and assist speed limiter! Still need to see if this gets the gps speed closer / more accurate over stock. Dunno. Can probably fudge this to get a few more assist mph too...

                edit: Might be best not to mess with tire and speed stuff. Stock is 90 km/h, highest you can change to is 60 km/h

                Now my bike displays 37 mph top speed. Stock reads 56 mph top speed. Oops. Not that gearing let’s it go that fast anyway... but I did adjust my tire size to 27.5 and circumference down to 2224 mm (stock is 28 and 2230mm respectively)

                edit 2: ref lashing back to 14.5 resets speed limit to 90 km/h but when you flash to 14.6 it sets it to 60 km/h and you can’t ever get 90 km/h back.

                same is true if you change tire size in 14.5 the best you can keep is 60 km/h

                there are also some differences between offline mode and rodneys login mode in max speed...

                also some oddities in changing top speed in 14.6 vs 14.5. If you change speed to 60 km/h before you flash to 14.6 you can get 60 km/h. Otherwise you’re stuck with 45 km/h after flashing to 14.6.

                oh well. Plenty fast still... but Luna it would be awesome if we could get our own accounts that have the 90 km/h option, and any other possible goodies / options unlocked. It seems the login sets flags and unlocks options for the user.
                Last edited by UCR1; 12-10-2020, 04:21 PM.

                Comment


                • Desmodromic
                  Desmodromic commented
                  Editing a comment
                  UCR1 can you confirm if "stock_x1_firmware__11007.bin" is the file that flashed as 14.6 on your bike? That's what I gathered from some other posts, but would like to confirm here.

                • UCR1
                  UCR1 commented
                  Editing a comment
                  I used the stock X1 from the download Luna emailed me when my BESST shipped. It’s 14.6. I believe that was the file name (I have since renamed mine to show 14.6)

                  Torque ramps seem solid with 14.6. I’m happy and will likely keep it this way unless they do something new in the future.
                  Last edited by UCR1; 12-10-2020, 04:26 PM.

                • A Henry
                  A Henry commented
                  Editing a comment
                  Great info! Amazing you figured out the speed update but it works just as you described. Thanks.
              Working...
              X