Announcement

Collapse
No announcement yet.

Loud Clicking Noise?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Loud Clicking Noise?

    Anybody recognize this click sound? Just started today. Bike as only been ridden about 50 miles and was running fine. I can hear and feel the clicking in the right pedal. Does Not click when only powered by throttle. Nothing seems loose. I turned the bike upside down and it will not click, also lift up the wheel and will not click. I guess because there is no load idk. Will click in any gear, the chain is straight. Clicks about the same spot in the pedal revolution. Im stumped!
    BBSHD, Lekkie bling ring
    video, sharing, camera phone, video phone, free, upload

    #2
    What's sticking out from the frame, back on the left stay, behind the left crank arm?

    Comment


      #3
      there is a speed sensor which cant cause any noise. but the noise is from the right crank arm area. doesnt feel loose but im going to dig in tomorrow

      Comment


      • crunch
        crunch commented
        Editing a comment
        Did you ever figure out your clicking noise? I had the same noise on the downward stroke under load. It is not getting better and seems maybe the chain and chain ring are wearing prematurely do to my aggressiveness.....

      #4
      Seems to be once per revolution of the pedals. Are you sure your crank arms are tight on the spindle?

      Comment


        #5
        Did you find the cause - I noticed that I have a similar sound

        Comment


          #6
          Heres how i fixed it. I turned off the power to the motor. Put it in 1st gear. Then stood up and pedaled hard about 20 - 30 times til the noise was gone. Powered back up and rode it until it did it again. Then i repeated over again. After about 3-4 times of this, it has never made that noise again so far. YW

          Comment


            #7
            Originally posted by Bobster View Post
            Heres how i fixed it. I turned off the power to the motor. Put it in 1st gear. Then stood up and pedaled hard about 20 - 30 times til the noise was gone. Powered back up and rode it until it did it again. Then i repeated over again. After about 3-4 times of this, it has never made that noise again so far. YW
            In fact, I did exactly the same, and for a while the knocking stopped. It also stops after a night stop - but reappears every now and then.

            Comment


              #8
              How tight does the motor shaft housing fit in your bottom bracket? And do your pedals have bearings or just a shaft through the body?

              Comment


                #9
                Originally posted by Dshue View Post
                How tight does the motor shaft housing fit in your bottom bracket? And do your pedals have bearings or just a shaft through the body?

                The stem fits tightly into the bottom bracket, and the pedals have no bearings (they have so-called polymer bearings). I changed them and that was not the cause.

                Comment


                  #10
                  Check your chainring for any defective teeth and check your chain for any tight links. Also watch your rear derailleur to see if it jumps to coincide with the noise.

                  Comment


                    #11
                    Originally posted by Dshue View Post
                    Check your chainring for any defective teeth and check your chain for any tight links. Also watch your rear derailleur to see if it jumps to coincide with the noise.
                    This is a dull low noise (knock) evidently coming from the center of the engine. Changing the load - i.e. changing the PAS to a lower one, or shifting to a higher gear - completely mutes the sound - it's as if I was not keeping up with the cadence, but I don't know exactly - this is my impression. Maybe I have to turn off the drive too quickly (5 ms) and slow down in the neutral position of the legs (up and down), the engine turns off - I don't know - it calms down a bit when I drag pedaling - a kind of SPD simulation - because I have platforms and not SPD, but I pull with pedals also horizontally - i.e. in the lower position - then the knocking stops.

                    Comment


                      #12
                      I have too have developed a similar Click/creak on the downward stroke of the pedals under load, I have changed shoe cleats and pedals but it still persists, all bolts and cranks are tight, no play any where,, I have also started having power down problems again, this on first switch on,, display comes on for a couple of seconds then powers off, it will do this several times before staying on, and during a ride will suddenly power off, All connectors have been disconnected cleaned with contact cleaner and reconnected. I hade a similar powerdown problem last year, but putting straps round the battery and frame seemed to stop any vibration and it was good until recently. so still puzzled !

                      Comment


                        #13
                        I’d love to know if there was ever a fix for this. Or what the issue was. I am also having a dull knock from bbshd under pedal load.

                        Comment


                          #14
                          Ref Loud Clicking Noise?

                          Loud Clicking Noise?
                          I had this problem and eventually traced to the Right hand crank not being absolutely tight, I thought that it was, until I tightened it again, that solved my problem

                          Comment


                            #15
                            My cranks are darn tight. As is the motor to the bike. For me it's something else. Seems to be coming from inside the motor but who knows? Only happens under load, I notice it mostly going up hills etc.. Happens regardless if motor is on or off. Seems to be getting worse/louder. I keep thinking one of these days I'm just going to hear a pop and that will be the end.

                            Comment

                            Working...
                            X