Announcement

Collapse
No announcement yet.

Bafang BBS02B suddenly power cut-off after hearing clicking noise inside the battery

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bafang BBS02B suddenly power cut-off after hearing clicking noise inside the battery

    I have the Bafang BBS02B 48V 500W model and while driving in PAS 3 mode without using the throttle, the battery made clicking noise twice and then the BMS cut the power off. I took the battery off from the mount. It was actually very hard to pull it off. I find out that the + connector inside the battery connecting housing burnt and probably melted with the connector from the battery mount holder. Battery is 48V 18,5ah from Hailong samsung 35E i think. I checked the voltage using my multimeter and it showed me 50,56V. I visually inspected the entire wire, which is connected with the motor and battery but looked good. Only the battery connector on the battery itself and the mount. I checked if the controller is shorted. Indeed it was shorted and moving the rear wheel backwards while elevated, there was a big resistance.
    Took the motor controller off, disconnected phase wires and no more big resistance when moving rearwheel backwards.
    The dealer at aliexpress shipped me a new controller and battery connector set.

    I uploaded some pictures about it. The controller smells burnt and i found something I marked it on the picture. I couldnt get the rest of the rubber off from the controller.

    The motor coil windings are probably okay because i was driving at PAS 3, which I set as 50% Power and 100% Speed. Controller max output set at 16A. I was also pedaling. Couldnt smell something there but did not try to disassemble the rest of the Motor.

    My Question: Might the battery took damage too? It is charging normally but dont know if it will work normally. I need to wait for the spare parts to try it.

    #2
    Originally posted by Bilal51 View Post
    My Question: Might the battery took damage too? It is charging normally but dont know if it will work normally.
    Based on what we've seen here before, your battery cells and BMS are likely ok - just the too-common burnt up tray connector. Hopefully what they've sent you to replace will get you going again.

    Please exercise extreme caution when replacing the battery pack connector - there's a lot of risky stored up energy in these batteries.

    Comment


      #3
      Originally posted by ncmired View Post
      Based on what we've seen here before, your battery cells and BMS are likely ok - just the too-common burnt up tray connector. Hopefully what they've sent you to replace will get you going again.

      Please exercise extreme caution when replacing the battery pack connector - there's a lot of risky stored up energy in these batteries.
      For anyone, who has the same issue like me: It was the blown motor controller, from which also the display suffered too. Battery is fine.
      The parts arrived yesterday. After installing the new motor controller and soldering new connectors, the motor still did not power on. The P850C Display stayed dark but then found out that the gear sensors LED flashes. The motor is powered on and it works using the throttle but the display is not working. I think it suffered from the blown controller too. I had luckily spare bafang 750C, which works now.

      Comment

      Working...
      X