Announcement

Collapse
No announcement yet.

[HELP] My ebike stops working below 50V

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [HELP] My ebike stops working below 50V

    Hi guys,

    I'm new here. I have a 48v 250W bldc hub motor that stops working as soon as the voltage goes below 50V. If I charge my battery to full, it works perfectly alright ultill the battery reaches 50v or below. The battery power bars in the display starts fluctuating and the motor rarely gets any power.

    I did check my charger voltage. Its isn't fluctuating nor my battery voltage is fluctuating. I did reset my BMS Too to see if this was a battery issue? But the issue remains the same.

    I have a DMHC controller with TC480 Display that allows me to change the 24/36/48V. When I switch to 36V the bike again works on very minimum power. If I use acceleration the bike gradually picks up with very less power.

    I'm totally clueless as to what is going on. I'm mostly assuming it's the controller which is at fault. The LVC ( Low voltage cutoff) for some reason has gone high suddenly. My bike was working fine untill last week when I tried to install a new ebike light but the 12V line had no power in it. The 12V line gets power only for 1 sec and them goes off. Can anyone help me with this. I'm attaching few photos for a better overview of the issue. Any help would be appreciated.

    Thanks in advance

    #2
    BMS ( Quick fix or at least to check is to open battery pack, and direct wire battery.. basically cut black and wire directly to load. Or you can reprogram the motor... (I have a bafang mid drive and can reprogram it)

    Comment


      #3
      My goto would be the battery more so than the controller although anything is suspect at this point - if I were a betting man....

      I would try loading the battery sans bike (use a skillet, toaster, space heater or very high watt incandescent bulbs, etc.) with a meter plugged in. If it drops abruptly at ~50V then the battery is likely hosed, if it keeps on dropping smoothly until ~40V then likely not the battery... since this may take a couple of hours depending on the battery (you didn't mention capacity or age or much of anything else =[ ) and load I'd just set a timer to around fifteen to twenty minutes or so to remind you to periodically check it and write down the time and voltage (and maybe amps) - this will tell you a ton about the battery, especially if you have two meters and can set one up to measure amps...

      Comment

      Working...
      X