Announcement

Collapse
No announcement yet.

Just picked up a Deluxe Fusion 500 and it is shutting off

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Highrpms
    replied
    It now turns of instantly. I'll bring it back to Luna on Monday.

    Leave a comment:


  • ykick
    commented on 's reply
    47V is basically empty for 52V pack.

    Blue Mini Charger? Email support@lunacycle.com as they'll probably have some options for that issue.

    In some cases you can leave that charger connected while clicking on/off for a day or more and somewhere around 51-52V it may start charging normally.

  • Highrpms
    replied
    Originally posted by Eric Luna View Post
    It sounds like your gong to have to swap out that battery unfortunately. . Next time your in LA area just arrange in advance and we will have a replacment ready for you. . In the meantime just keep the power levels down and you will be good to ride.
    Thanks. The charger doesn't appear to be working. The lights just click on and off and same with the fan.

    Leave a comment:


  • Eric Luna
    replied
    It sounds like your gong to have to swap out that battery unfortunately. . Next time your in LA area just arrange in advance and we will have a replacment ready for you. . In the meantime just keep the power levels down and you will be good to ride.

    Leave a comment:


  • Just picked up a Deluxe Fusion 500 and it is shutting off

    Hello, First post. I just picked up a Fusion 500 at the Luna Shop with the Ludicrous 2500W. It's fully charged and it shuts off to a blank screen almost instantly at level 2 and up and/or when the throttle is depressed more than 10% under load. Volts will drift down to 47. Any ideas? I'm hopeful to not have to take the bike back. It's 3 hours round trip. Thank you
    Last edited by Highrpms; 10-13-2017, 06:47 PM.
Working...
X