Announcement

Collapse
No announcement yet.

Controller wiring issues?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Controller wiring issues?

    First post, will make it as short and specific as possible. I have built a ebike using a bafang 750w hub motor, and lunacycle was out of stock when I made the purchase from an Amazon store seller that appears to speak English about as well as a water logged furby. I did however order a 48v dolphin from lunacycle, and I doubt that it's the problem. The controller that came with it stopped working while I was riding down hill, my display cut off, wouldn't cut back on. So I purchased a new 48v 1000w controller from another seller and that fixed the problem and everything was great. Today I was riding to work and my wiring to the controller from the battery malfunctioned, so I just rewired the hot with a small wingnut, the display cut back on and I rode another 100 feet or so on flat ground- then display went out again. I reconnected the red and rode another 50 feet and then it failed again. So I pedaled on to work, soldered the battery wires to the controller's after stripping it and exposing fresh copper. Displayed turned on and I began to ride it, 30 feet later it stopped. The battery has nearly half full charge, the controller wasn't heated, nor the motor and battery. Is there something I'm overlooking?

    I'm a lurker on here and endless sphere for the last several months, I've learned a lot but I am still fairly ignorant to even the simplest of technical problems.

    If anyone can help that would be great! My feelings won't be hurt, if I'm doing something stupid let me know. Lol I want to learn all there is to know about ebike maintenance and building. Is the controller needing to be replaced entirely or is there another solution I haven't discovered? I will edit this post with the link to the controller used if that makes a difference. To me it seems like even with a good strong connection to the battery it still keeps cutting off the fact that it's 1000w shouldn't be an issue, motor runs fine when it's working.

    #2
    Lots of things to wonder about. Sounds like more than one bad connection, if a battery cable comes undone while you're riding.

    What kind of display/controller? Is this the original display or a second one. Dolphin with power switch and LED display? Did you solder the negative wire too?

    By the way, I once had the hex nut that goes around the connector on my Dolphin fall off, so it was loose when I mounted the battery in its cradle. One mile into a big ride, I lost power. I did go 20 miles pedalling. Figured it out when I got home.





    Comment


      #3
      Hard to tell if battery pack is truly 1/2 charge? if the connections are solid then it's probably time to look at the battery pack?

      Please tell us you're not practicing 80% charge regime? If so, the cell groups will likely become out of balance and the pack could be cutting OFF as described? Please charge 100% and leave it connected to charger for 12-24 hours after it appears fully charged. The BMS needs that time or perhaps longer to balance cell groups.

      Comment


        #4
        https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1 this is the controller.

        The display
        https://www.amazon.com/Intelligent-Control-Display-Electric-Conversion/dp/B06XS51NR1/ref=sr_1_1?s=sporting-goods&ie=UTF8&qid=1508798243&sr=1-1&keywords=Kt+lcd5

        the battery (13.5ah)
        https://lunacycle.com/batteries/pack...3-5ah-dolphin/

        I soldered both positive and negative. When I went home I cut them and then twisted into wingnuts, after exposing fresh wire. I lifted my rear tire and hit the throttle and it spun at max speed for about 2 minutes before I released the throttle, after that I tried riding it and less than ten feet I lost power. I've fully charged the battery over night and then about 12 hours the next day continuously. I only bought the battery about a month ago and have never drained it below about 30 percent or so. The it lcd5 display that came with the motor is the only one I've ever used, however it doesn't seem to completely work properly with the new controller it doesn't read the battery level, nor does it provide speed and distance, the throttle worked perfectly for a few dozen miles so far.

        so far when the power is lost, as long as I just disconnect the positive and negative and then reconnect them- it provides power. They aren't losing connection when power is lost so to me that sounds like the controller is damaged somehow, just weird that it didn't behave this way from the beginning.

        I should probably look into purchasing a better controller anyways, does anyone have a recommendation? The hub motor controller on LC
        Looks to be a good choice but the connectors are not like the ones I currently have I think. If I can switch my throttle and display connectors I will learn how to if the controller is compatible. I've searched google and the forums, but not definitely sure what would work best for me, I prefer reliability over speed. If I can repair the controller for the time being, I'll do that, but I'm definitely not qualified lol.

        Thanks for your help so far.

        Comment

        Working...
        X