Announcement

Collapse
No announcement yet.

How to connect battery to controller?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How to connect battery to controller?

    Well I can't even get the charger to charge the battery and there a circuit board that says LunaCycle on it, no clue what it does, no way to connect. Both lights on and not charger battery or it's already charged which makes no sense if it is

    I have no connector to connect to battery. I think it's this red connector in the picture but it's WAY different then what is connected off the battery. I can't even test to see if anything works. Do i need to cut the connectors off and somehow connect them?

    Ive found no instructions anywhere online to show how to do this. I have no clue what i'm really doing but it makes no sense to me two entirely different connectors.

    forgot pictures...https://imgur.com/a/akuTh
    https://imgur.com/a/78BcT
    Last edited by Valmek; 11-04-2017, 11:54 AM.

    #2
    You will likely have to change one of the connectors on your controller to match the discharge lead on your battery. If you have no clue what you are doing, a Cyclone install is going to be a problem.

    Comment


      #3
      https://electricbike.com/forum/forum...ng-the-cyclone

      Comment


        #4
        Originally posted by Peter Halt View Post
        You will likely have to change one of the connectors on your controller to match the discharge lead on your battery. If you have no clue what you are doing, a Cyclone install is going to be a problem.
        Well that's the only thing, everything else is connected but the battery to the controller. I read to cut the connector off the controller and connect this connector that came with battery with a butt splice to work. I've not done anything like that and before i start cutting wires and shit i want to make sure so i don't fuck anything up.

        Comment


          #5
          https://www.electricbike.com/matchin...to-controller/

          Comment


            #6
            Hi, Valmek. It looks like you have everything to charge your battery. Your battery has two pairs of power wires. The thicker pair are for riding, these connect to the controller. The thinner pair connect to the charger. Plug in the charger to AC 120v. Connect the orange/yellow (dean's) connector from the battery to the same color connector on the charger (the thinner pair of wires for charging) If no charging get out the manual that came with your bike and see if there are any fuses that may need to be replaced or installed. Also look if there is a reset switch or any breaker that would need to be reset. It can be possible too also to have a problem with the circuit board, or the battery pack or even the charger. If this may be the case then get service from Luna. Another thing but less likely could be a requirement for the battery to be connected to the controller in order to charge. Those are the thick pair of wires coming from the battery that connect to the controller. Good luck!
            Last edited by jcebike2017; 11-11-2017, 05:10 PM.

            Comment

            Working...
            X