Announcement

Collapse
No announcement yet.

Installation problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Installation problem

    Hi, I recently purchased a BBSHD with a shark battery pack. The installation went relatively smoothly. But when I try and turn it on it doesn't work. The display lights up, and you can choose which level of pedal assist etc. But when I press the power button on the battery pack the lights don't stay on. They only light up while i have my finger on the button. At first I thought it was a faulty battery, and so I had it replaced, but it is still happening and so it must be something else. I have checked all the connections, and they seem fine. I was hoping that someone may have an idea what to check next?

    #2
    The Shark pack doesn’t have an on/off switch. The button you’re pressing is just a cheap charge monitor that is a temporary switch.

    Comment


      #3
      If the display lights up, you should be good to go. Does the motor run with throttle on?

      Comment


        #4
        Ok well that's good news at least about the power switch on the pack. I don't know why the guy who sold me it didn't say anything, because I had mentioned it several times before I sent the original battery back for a replacement. I just assumed you had to switch the battery on to be able to use it.

        Yeh the display lights up, but when I press the throttle I get nothing, changing the pedal assist levels and pedalling I get nothing. Luna Mate directed me to a video they had made to check the BBSHD Phase Wire. I opened it up and couldn't see anything wrong, everything was connected. I was as gentle as I could be to not pull any wires loose. I couldn't see anything obviously wrong, but screwed the unit back together now I don't get any power to the display. So that made things worse. I don't know anywhere in Brisbane that could look at the thing for me. I have emailed a few electric bike sellers to see if they can take a look but I have had no response.

        So far I have paid 2 grand to make my bike heavier and have no front gears. Its quite frustrating.

        I made some videos of before, during and after pulling it apart, and I sent it to them hoping they can see something I can't. Will see what they say.

        Comment


          #5
          They have offered to replace the motor, which is great. The customer service was very helpful. Hopefully I should be zooming to work in no time

          Comment

          Working...
          X