Announcement

Collapse
No announcement yet.

BBSHD Creaking sound when pedaling - not when motoring

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    BBSHD Creaking sound when pedaling - not when motoring

    My recently installed BBSHD has about 50 miles on it. Previously it was smooth as silk, no creaks or squeaks. The last 10 miles it started creaking loud on the downstroke of the right pedal. Basically once per pedal-rotation with a couple of minor mini-creaks after the loud one. (Mini-creaks also 1x per pedal-rotation.)

    Interestingly there's no creak at all when motor engages for pedal-assist - maybe because it's consistent torque? But I've tried standing on the pedals to give bursts of torque while motor going, and still no creak. (I don't have throttle so can't test that). I've tightened the chainring bolts, removed/greased/retightened the pedals, removed/re-tightened BBS nut and black lock-ring, and removed/retightened the cranks.

    Seems like the fact that it doesn't happen during pedal assist is significant. Also - there's a tiny bit of lateral play (<1mm) in the shaft that goes through the bottom bracket - I've read threads about that and seems like under 1mm there is normal and acceptable. Should I take everything apart and tighten again? Put on some proper Shimano cranks? Try putting one of these in to reduce lateral play? https://california-ebike.com/shop/ba...pacers-set-3/? Any other ideas?

    Thanks!!

    #2
    An idea: Is this retaining bracket spaced correctly on your build? (parallel w motor)

    Comment


      #3
      Did you ever find out the problem? I’m having the same issue

      Comment

      Working...
      X