Announcement

Collapse
No announcement yet.

Focus Jam LTD won't power up?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Focus Jam LTD won't power up?

    Hi guys, I bought a barely used Focus Jam2 LTD for my wife which she loves. She used it on Sunday and I washed it and turned it upside down to remove the wheels to set them up tubeless. It was upside down overnight and now it wont power up. When i connect the charger it starts to charge and then it goes to a red flashing light on the battery which apparently is a charging fault according to the manual. Can anyone make any suggestions as to what might be the issue or is there a master reset that could be done.
    thanks in advance
    regards
    David Dobson.

    #2
    In-frame Battery? If so, I'd pull it and check for water intrusion. Is there a LED indicator on the charger block itself? If so, is it also showing an error?
    BBSHD/BBS02B builds: IGH 1 2 3 4 5 6

    Comment


      #3
      Yea, in-frame battery but no led battery indicator other than the LCD display which wont power up. Strangely tho if I bounce the whole bike on the floor the start-up button will light up as if itvwas going to fire up and then it fades again

      Comment


        #4
        The charger itself has two green lights and a red error light. When I connect it to the bike it starts as normal but then after about 20 seconds the red warning light comes on.

        Comment


          #5
          Did you resolve this problem? Mine did same yesterday while out on a route and behaves the same way if I bounce it - a brief light on the on button. Cheers, John

          Comment


            #6
            I know this is an old thread, but my Jam2 is doing exactly the same. Did you guys find the issue?

            Comment


              #7
              It looks like both the people that had this issue were only here to ask these questions and haven't been online since which was over a year ago for one and over 2 years for the other.

              Did you get it wet and flip it upside down too? Or just get it wet? Or just have the same symptom where the light kinda looks like its going to be happy and turn on but then fades?

              Comment


                #8
                Hey Guys,

                I have exactly the same issue. The only difference for me is that my bike was fine until I plugged in the tec pack (optional Battery)

                Please help.

                Comment

                Working...
                X