Announcement

Collapse
No announcement yet.

Speed controller and or foot throttle isn't working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Speed controller and or foot throttle isn't working

    Hello,
    I'm trying to get my son's go cart running this summer. At the first use of the season it was dead. I replaced the speed controller, didn't help. Then I replaced the foot throttle, didn't help. It runs when I connect the the outer wires on the throttle connector. So the speed controller should be working. But the new throttle isn't.

    Is there a way to check if it's working? What could the problem be?

    Ordering a new throttle from China would take too long before arrival.

    Best regards

    #2

    Comment


      #3
      Welcome aboard Bajken!

      I would speculate that the controller uses input from a hall sensor throttle for control. Is your new foot throttle a hall throttle device? (make and model) If so the controller needs an input signal of ~.9vdc to ~3.5vdc to operate, typically a blue wire.
      Jumping the outer wires, Red and Blue (or green?) would give the controller a 5vdc signal. Does the throttle wiring match with the controllers? Wired correctly? To check operation, see that 5vdc is making it to the throttle. Red (5vdc+and Black (battery ground) wires. Then check the sensor out wire to ground to see if your getting required output. What you have or find will determine where to go next...

      Wiring colors used here are typical just for discussion, but must be verified as to which is what on your system. As colors vary widely.

      Good throttle troubleshooting guide...

      See this for the hall sensor pinouts... http://sensing.honeywell.com/index.php?ci_id=50359

      Regards,
      T.C.
      See my completed Magic Pie V5 rear hub motor E-Bike build HERE.

      Comment


        #4
        Originally posted by Tommycat View Post
        Welcome aboard Bajken!

        I would speculate that the controller uses input from a hall sensor throttle for control. Is your new foot throttle a hall throttle device? (make and model) If so the controller needs an input signal of ~.9vdc to ~3.5vdc to operate, typically a blue wire.
        Jumping the outer wires, Red and Blue (or green?) would give the controller a 5vdc signal. Does the throttle wiring match with the controllers? Wired correctly? To check operation, see that 5vdc is making it to the throttle. Red (5vdc+and Black (battery ground) wires. Then check the sensor out wire to ground to see if your getting required output. What you have or find will determine where to go next...

        Wiring colors used here are typical just for discussion, but must be verified as to which is what on your system. As colors vary widely.

        Good throttle troubleshooting guide...

        See this for the hall sensor pinouts... http://sensing.honeywell.com/index.php?ci_id=50359

        Regards,
        T.C.

        Problem solved! I had wired the hall sensor incorrectly.

        Instead of connecting red-red etc I had put them in the same order in the connector, which was different in the new controller compared to the old one.

        My new controller is as pictured above, the very generic one available on eBay and more places.
        The old one was the exact same shape and size but had slightly different connections.

        The old had a 3 stage speed limiter which was very good for the go-kart, so it could be used by younger kids.

        The new on has a connector labeled "sport", two wires going in to that.
        I tried full speed with it open and closed, no difference.
        Anyone know how that is supposed to work on those?


        Comment

        Working...
        X