Announcement

Collapse
No announcement yet.

Please Help Bafang BBS02 is installed but wont turn on.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Please Help Bafang BBS02 is installed but wont turn on.

    Please help. I've been working on my chopper ebike and I have almost everything set up (still waiting on extra long brake and shifting cables) and connected, but it wont turn on. I charged my battery to full power and havent used it yet. Did I miss something? The whole kit came with zero instructions so I watched a lot of videos online put it together. I thought it was pretty straight forward. Everything seems to be in line but I'm getting nothing on my DPC 18 display screen. I dont even know where to start.

    Is there a fail safe feature that wont let it turn on if the brake and shifting cables are not installed?

    Is there something about turning it on that I am missing?

    I'm getting a little worried because I doubt I will Bafangussadirect.com is going to get back to me soon.


    #2
    The only thing I can think of that went wrong during the installation was the battery was attached when I connected the battery mount to the motor and I got a little spark, would that short it out?

    Comment


      #3
      Are you holding the power button down for a few seconds?

      Comment


        #4
        Are the display wiring connectors correct?

        https://electricbike.com/forum/forum...e-to-seem-dead


        Edit: Sorry this is for a 14, my mistake...

        To make up for that, here is a link to troubleshooting a Dead BBS02. :-)

        http://electricbike.com/forum/forum/...bs02#post39217
        Last edited by Tommycat; 08-17-2018, 12:59 PM.
        See my completed Magic Pie V5 rear hub motor E-Bike build HERE.

        Comment


          #5
          Great looking chopper. Tell us it works now,

          Comment

          Working...
          X