Announcement

Collapse
No announcement yet.

Bafang Ultra Mid drive power output issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bafang Ultra Mid drive power output issues

    Hey Folks,

    Hoping some of you smart/experienced Bafang ebike people(maybe those with Ultra motor kit knowledge..if any) might know whats up with my bike and have some ideas how to resolve. I've got an Ms2 All Terrain Ultra Fat bike. Just recently got it. It utilizes the Bafang Ultra Mid Drive kit. All in all a very nice bike. But, I'm having power output issues. Essentially when I ride on a flat surface for 2 miles or so on level 3, and peddling, it starts off with lots of power (varying power from 0 to 1500 watts..a bit erratic though)...but then after 2 miles I start to loose power whereby the most it will indicate on the Bafang screen is 500 watts output which for me equates to about 15 miles an hour with vigorous peddling in a mid gear. All test rides were in cool weather and on flat paved roads with 30psi in the tires. Bike actually coasts quite easily and effortlessly...so sure doesn't seem like Im working it hard. I've talked to Ms2 whereby there Bafang rep is indicating this is likely due to new power mgt software tweaks Bafang recently made to their Ultra Motor kit as they were having too many motor failures due to heat and burned up motor cores(design issues?). But, all this info seems to be guesswork..and its been quite hard to get good information on whats up. I did notice Luna cycle now offers the Bafang Ultra Magnesium kit with there own custom tuning...whereby Im wondering if they are aware of these problems and have solved them via the software improvements and tuning?? But, I havent been able to get through to them on the phone. Thx for the help...
Working...
X