Announcement

Collapse
No announcement yet.

Losing power

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Drzdave58
    replied
    Originally posted by Defjr333 View Post

    It's not a Ruffian. It blows the Ruffian away.
    Ruffian tops out at 20mph and apox 50 miles. Mine does 40+ and 100+ miles. I built it with the standard Basman frame and parts from Ruff-cycle. But it is powered by Luna products. Bbshd, dual 12.5 ah packs etc. It has many things the Ruffian could never do.......and it was about HALF the price.
    Ruffian $5600
    Mine. $2500
    ​​​​
    SWEET!!...very smart...yeah..I just got a new controller on my BBS02...my bike tops out at 49 kmh...custom build is the best way to go..

    Leave a comment:


  • Defjr333
    replied
    Originally posted by Drzdave58 View Post

    Yes...ruff Lucky frame.I see u have the ruffian huh?...nice ride!
    It's not a Ruffian. It blows the Ruffian away.
    Ruffian tops out at 20mph and apox 50 miles. Mine does 40+ and 100+ miles. I built it with the standard Basman frame and parts from Ruff-cycle. But it is powered by Luna products. Bbshd, dual 12.5 ah packs etc. It has many things the Ruffian could never do.......and it was about HALF the price.
    Ruffian $5600
    Mine. $2500
    ​​​​

    Leave a comment:


  • Drzdave58
    replied
    Originally posted by Defjr333 View Post
    A friends BBS02 did this and was determined, after MANY back and forths with different ebike techs, to be the controller. He replaced it and has not had the issue since. Hey Drzdave.....I see that Ruff-Cycle frame. LOL
    Yes...ruff Lucky frame.I see u have the ruffian huh?...nice ride!

    Leave a comment:


  • Defjr333
    replied
    A friends BBS02 did this and was determined, after MANY back and forths with different ebike techs, to be the controller. He replaced it and has not had the issue since. Hey Drzdave.....I see that Ruff-Cycle frame. LOL

    Leave a comment:


  • Drzdave58
    replied

    Leave a comment:


  • Drzdave58
    replied
    My battery is mounted same as yours....

    Leave a comment:


  • Neville
    replied
    My Battery is mounted on the bottle cage bosses on the down tube ans seems quite secure

    Leave a comment:


  • Drzdave58
    replied
    Originally posted by Drzdave58 View Post
    You could just have a bad battery connection...riding bumpy roads can affect your battery connection...I was having a similar issue with mine...I wrapped 2 zip ties and two Velcro straps around the battery housing to secure it better...haven’t had a problem since..where is your battery mounted?
    Have u tried this?

    Leave a comment:


  • Neville
    replied
    Hi
    My name is Neville and I am in New Zealand, I am running a BBSHD, 52 v Battery and a DPC18 display. currently i have ridden about 1500 km on the road, without problems, most of it on PAS 1-3. recently I have started having an intermittent shutdown during a ride, The display goes off with the resulting loss of power, Sometimes I can power it up almost immediately and other times it takes several attempts.
    I have checked the connections and the Speed controler/magnet and all seem to be correct Has anyone else experienced this problem ?

    Leave a comment:


  • Drzdave58
    replied
    I just had the latest new controller put on my bbso2..cause of my losing power issue...my bike seems to accelerate faster and top speed has improved...I’m glad I had it replaced ...I’ve had no more issues...

    Leave a comment:


  • mattman2714
    replied
    Thanks for the reply. I thought about that at first but it started doing it while I had the bike on the repair stand.

    I've checked all the connections and the voltage on the battery and everything seems fine there.

    When it starts cutting out the display remains active but the motor will just stop spinning. Sometimes it cuts back in and other tomes the display will go dead after a few seconds requiring a restart.


    I am starting to think it might be a controller issue

    Leave a comment:


  • Drzdave58
    replied
    You could just have a bad battery connection...riding bumpy roads can affect your battery connection...I was having a similar issue with mine...I wrapped 2 zip ties and two Velcro straps around the battery housing to secure it better...haven’t had a problem since..where is your battery mounted?

    Leave a comment:


  • mattman2714
    started a topic Losing power

    Losing power

    Hi I've got a new battery pack about 2 months ago for my bbs02.

    Been working fine until the past week. The motor intermittently stutters while riding (both with throttle and pas) then the system will completely shutoff. I can usually power it back on immediately and keep going. Sometimes it will stutter and keep going other times it will power off multiple times.

    It doesn't happen every ride and usually after a couple of power cycles it will keep going fine.

    Any ideas on where to start looking?
Working...
X