Announcement

Collapse
No announcement yet.

Bafang BBS02 throttle works but pedal assist does not

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Bafang BBS02 throttle works but pedal assist does not

    I'm at my wit's end with this problem that I'm having and hoping that somebody here can help me troubleshoot.

    I bought a second hand Bafang BBS02, 750w kit. I put it on my bike and everything works except for the pedal assist. The throttle works fine, the walk assist works fine, but when I pedal, there's nothing. Speedometer works fine too.

    I have no way of knowing if the pedal assist was turned off via the programming cable, but I feel like the seller would have disclosed that.

    Theory:

    During the installation, I had to splice the red and black cables and put a new butte connector onto the battery leads. The black and red wire from the motor momentarily touched (not connected to battery) and there was a small spark. Could I have blown something? If so, what could have blown for the pedal assist to stop working?




    Thanks so much for any help!

    #2
    Hi cheesusmurphy,
    And welcome to the forum!

    Hopefully it's just a loose connector... see this post.

    https://electricbike.com/forum/forum...3604#post93604



    Regards,
    T.C.
    See my completed Magic Pie V5 rear hub motor E-Bike build HERE.

    Comment


      #3
      Thanks Tommycat!

      I opened up the motor and disconnected and reconnected the PAS connector just to make sure it was seated corrected and unfortunately I'm still having the same problem :(

      Could it be the PAS disk or PAS sensor board? If so, what should I look for when I check it?

      Also, when I bought the used BBS02, the previous owner lost the magnet. I retrofitted a fridge magnet and it's strong enough to trigger the red light on the speed sensor, but I've noticed that in certain positions, it'll get the motor to whir a little as it passes. Could it be that the magnet is too weak even though it's strong enough to trigger the red speed sensor light?

      Comment


        #4
        These magnets work great. https://www.ebay.com/itm/CatEye-Whee...72.m2749.l2649

        Comment


          #5
          Never had to troubleshoot a Bafang Pas system, but I'll tell you what I know.

          A PAS sensor typically has three wires that correspond to it... (note wire colors to function are speculated) 5vdc input, ground, and sensor output. Since you have 5vdc for the throttle I would think that you'd have it for the PAS. (check Red (+5vdc) to Black (0vdc-ground) Thinking that the Grey wire is the output. (check Grey to Black for 5vdc to 0vdc back and forth switching when crank is turned)

          That leaves the White wire which I would guess puts out a PAS signal when the crank is rotated in reverse... available to actuate regen braking? (pure speculation)

          I've heard of both cracked PAS magnet discs and shorted PAS sensor boards/wiring causing problems.

          Information on the Bafang PAS systems seems scarce, so if you can supply actual hands on information, please pass it along. (will get it added to the wiring diagram)


          As far as the speed sensor goes. If the magnet is actuating the LED light every time consistently, with proper speed indication and no error code. (it just gives an electrical "pulse" for the speedo) I don't see how that could effect the motor. But interesting sound issue...

          Hopefully this primes the pump a bit for those Bafang PAS users to chime in!

          Programming is so impressive with this controller I couldn't pass up getting a cable and double checking on your settings!
          Last edited by Tommycat; 09-27-2019, 01:27 PM. Reason: Got the white and grey wire color operations reversed... corrected.
          See my completed Magic Pie V5 rear hub motor E-Bike build HERE.

          Comment


            #6
            I've uploaded some pictures of the pas magnetic disk, the sensor board, and the connectors to the controller. To me they all seem fine. The disk seems to be unbroken, the board seems to have all of their connections, nothing seems awry.

            Can only a part of the controller fail? If the controller is going, I don't know why the throttle and the walk-assist is working perfectly fine. If I turn the cranks, ssoommmeeettiimmeess the pedal assist engages for a split second (with or without the speed sensor).
            Last edited by cheesusmurphy; 09-23-2019, 07:38 PM.

            Comment


              #7
              I have the exact same problem, did you ever figure it out?

              Comment


                #8
                I've got the same problem as well. This means this is common to the bbs02. Did you get it sorted?

                Comment


                  #9
                  Yes it’s fixed!

                  I replaced the pas sensor, super simple fix

                  Comment


                    #10
                    Hey! OP here, also just chiming in.

                    I finally ordered a programming cable as a last resort and changing the speed profile actually fixed it! I also thought that it was the PAS sensor at first, but when I inspected it, it looked fine. The programming cable was a hail mary because nothing indicated that it was a programming issue but I'm so happy that it worked. So if nothing else works, try resetting the programming.

                    Comment


                      #11
                      Cheers for the replies I'll give them all a try and let u know.

                      Comment

                      Working...
                      X